Jump to content


Photo

Phpmyadmit Refuses To Work


  • Please log in to reply
18 replies to this topic

#1 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 November 2012 - 06:46 AM

I followed all of the instructions and it still does not work.Here is the instructions

here is my error


cannot load mysql extension;
please check PHP configuration


<snip mod: removed hundreds of lines of copy/pasted phpmyadmin instructions and phpmyadmin config file>

Edited by PFMaBiSmAd, 19 November 2012 - 08:03 AM.


#2 gristoi

gristoi

    Advanced Member

  • Members
  • PipPipPip
  • 846 posts

Posted 19 November 2012 - 07:33 AM

do you have mysql installed on your machine?
To err is human... to really foul up requires the root password

#3 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 November 2012 - 07:46 AM

yes I do it was installed sucessfully

#4 PFMaBiSmAd

PFMaBiSmAd

    Advanced Member

  • Staff Alumni
  • 16,767 posts
  • LocationColorado, U.S.A.

Posted 19 November 2012 - 07:59 AM

I followed all of the instructions and it still does not work.Here is the instructions

here is my error


cannot load mysql extension;
please check PHP configuration


You need to enable php's mysql extension in your php configuration (php.ini)

How you do this depends on how you obtained and installed php. ?
Signature: (not a comment about anything you posted unless specifically indicated)
Debugging step #1: To get past the garbage-out equals garbage-in stage in your code, you must check that the inputs to your code are what you expect.

Programming is just problem solving, but it is done in another language. You must learn enough of the programming language you are using to be able to read and write code.

#5 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 November 2012 - 08:29 AM

Like this you can see that mysql has been uncommented in my php.ini file


;extension=php_mssql.dll
;extension=php_msql.dll
extension=php_mysql.dll
extension=php_mysqli.dll
;extension=php_oci8.dll
;extension=php_openssl.dll

#6 PFMaBiSmAd

PFMaBiSmAd

    Advanced Member

  • Staff Alumni
  • 16,767 posts
  • LocationColorado, U.S.A.

Posted 19 November 2012 - 08:50 AM

Did you stop and start your web server to get any changes made to the master php.ini to take effect?

Did you use a phpinfo statement in a .php script to confirm that the mysql extension got loaded?

Are you sure that is the php.ini that php is using?
Signature: (not a comment about anything you posted unless specifically indicated)
Debugging step #1: To get past the garbage-out equals garbage-in stage in your code, you must check that the inputs to your code are what you expect.

Programming is just problem solving, but it is done in another language. You must learn enough of the programming language you are using to be able to read and write code.

#7 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 November 2012 - 09:48 AM

I restarted both mysql and apache I am looking at php info but dont know what to look for because I did not find anything about mysql

#8 PFMaBiSmAd

PFMaBiSmAd

    Advanced Member

  • Staff Alumni
  • 16,767 posts
  • LocationColorado, U.S.A.

Posted 19 November 2012 - 09:56 AM

If mysql doesn't appear in the phpinfo output, it's not enabled.

The Loaded Configuration File line in the phpinfo output is the php.ini that php is using. Make sure that's the one you are changing.

If you are changing the correct php.ini how did you obtain and install php, as the determines how you enable php extensions or if you need to make further changes to the php.ini to get php to be able to find the extension .dll files?
Signature: (not a comment about anything you posted unless specifically indicated)
Debugging step #1: To get past the garbage-out equals garbage-in stage in your code, you must check that the inputs to your code are what you expect.

Programming is just problem solving, but it is done in another language. You must learn enough of the programming language you are using to be able to read and write code.

#9 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 November 2012 - 10:54 AM

This might be a dumb question but would the information about mysql in php info be plain english?I want to know what to look

thank you

#10 PFMaBiSmAd

PFMaBiSmAd

    Advanced Member

  • Staff Alumni
  • 16,767 posts
  • LocationColorado, U.S.A.

Posted 19 November 2012 - 11:03 AM

Yes, if its enabled, there's a section of settings with a bold mysql heading.
Signature: (not a comment about anything you posted unless specifically indicated)
Debugging step #1: To get past the garbage-out equals garbage-in stage in your code, you must check that the inputs to your code are what you expect.

Programming is just problem solving, but it is done in another language. You must learn enough of the programming language you are using to be able to read and write code.

#11 gristoi

gristoi

    Advanced Member

  • Members
  • PipPipPip
  • 846 posts

Posted 19 November 2012 - 11:45 AM

if your uncommenting dll's then i can presume you are using a windows machine. Why not try a couple of alternative server stacks that have everything in place for you. Zend server community edition comes with phpmyadmin pre configured for you, and WAMP is alos a good server to use.
To err is human... to really foul up requires the root password

#12 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 19 November 2012 - 12:22 PM

PLease be pateint with me I am only starting out.I see there is a heading for sq lite and that sq lite has something to do with databases.That has nothing to do with my sql right?

#13 Christian F.

Christian F.

    Advanced Member

  • Staff Alumni
  • 3,106 posts
  • LocationNorway

Posted 19 November 2012 - 11:41 PM

SQLite is an alternative to MySQL and other databases, which can without problems be enabled (or disabled) completely unrelated to any of the other DB alternatives.
So, no: It has nothing to do with "your sql".

Have you verified that you're editing the proper php.ini file?
Keeping it simple.

#14 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 20 November 2012 - 02:39 AM

yes that I am sure off.I will go through all the "adjustments" I made to php.ini when I first "installed" it otherwise I will use another pc.I am thinking instead of installing php 5 because that is the one used it my book I will install the latest and instead of installing phpmyadmin 2.6.4.p1 I will install the latest I am also going to use a windows installer instead of copying files like david powers told me too.

Hopefully I can follow the book using diffrint versions of these programs

#15 gristoi

gristoi

    Advanced Member

  • Members
  • PipPipPip
  • 846 posts

Posted 20 November 2012 - 04:41 AM

this will give you everything you need to start coding in php with minimal effort:
http://www.wampserver.com/en/
To err is human... to really foul up requires the root password

#16 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 20 November 2012 - 07:24 AM

really intresting thank you I will study it in detail

#17 drunkelf

drunkelf

    Member

  • Members
  • PipPip
  • 16 posts

Posted 21 November 2012 - 02:37 AM

it works baby!sadly my book by david powers uses difrrint versions of these programs but he did say to install the latest versions availible so I am sure that I will be able to make sense of it.This wamp server thingy is so cool so easy.You can close the thead now

#18 priyankagound

priyankagound

    Advanced Member

  • Members
  • PipPipPip
  • 59 posts

Posted 12 September 2013 - 07:19 AM

This may be helpfull to solve your problem.

 

you need to start MYSQL from configuration system.



#19 mac_gyver

mac_gyver

    Advanced Member

  • Administrators
  • 2,707 posts

Posted 12 September 2013 - 08:57 AM

@priyankagound - perhaps you missed this - NOTE: This topic is marked as solved and might not require further action

multi-purpose programming fool. well written source-code should be self-documenting. well written code should be self-troubleshooting. 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cheap Linux VPS from $5
SSD Storage, 30 day Guarantee
1 TB of BW, 100% Network Uptime

AlphaBit.com