Jump to content


Photo

Phpmyadmin Got A Packet Bigger Than 'max_Allowed_Packet' Bytes


  • Please log in to reply
2 replies to this topic

#1 MSUK1

MSUK1

    Advanced Member

  • Members
  • PipPipPip
  • 189 posts

Posted 26 December 2012 - 10:47 PM

Hello

I am trying to upload an SQL file to my new VPS. However i keep getting this error:

#1153 - Got a packet bigger than 'max_allowed_packet' bytes

I've contacted my host and they've said phps upload limit is 2M and the packetsize is too small

Ive checked my php ini file, upload size is 128M and the packet max is 16M

What am i doing wrong?

The filesize is just over 2MB

#2 requinix

requinix

    Transforming Moderator

  • Moderators
  • 6,029 posts
  • LocationWA

Posted 27 December 2012 - 06:00 AM

That's a MySQL error about a MySQL setting. Not related to PHP. Do a query
SHOW VARIABLES LIKE 'max_allowed_packet'
to see what it's set at (measured in bytes).

Assuming that won't change and/or is set to something reasonable (fair assumptions) work around the limit by splitting your SQL file into smaller pieces and running them individually.

#3 MSUK1

MSUK1

    Advanced Member

  • Members
  • PipPipPip
  • 189 posts

Posted 28 December 2012 - 10:39 AM

Thanks for the response, i think i'll do as you suggested split the sql into several partitions.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cheap Linux VPS from $5
SSD Storage, 30 day Guarantee
1 TB of BW, 100% Network Uptime

AlphaBit.com