Jump to content


Photo

upgrade 5.5


Best Answer requinix, 31 July 2013 - 03:20 PM

I see a 5.5.1 in the downloads page so yes, there is a version there you can upgrade to. But you know you don't have to upgrade at all, right?

By the way, unless you're ready to spend the time testing your website in 5.5 and know that you'll be able to host it in a place that supports 5.5, stick with 5.3 or 5.4 for now. Go to the full post


  • Please log in to reply
5 replies to this topic

#1 jaykappy

jaykappy

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts

Posted 31 July 2013 - 08:25 AM

with recommendation of trq and strider64 ...I was looking into using 'password_compat' to handle my password hashing.

I noticed that I was still using PHP 5.3.19 and 'password_compat' requires 5.3.7....

I assume that any newer version will work just fine?

 

What is my best practice for updating my PHP version.  Will this interfere with anything I already am running on my website?

 

I think that I simply need to download the newer version then in IIS Manager under PHP setup click 'register new PHP version' and point to the new exe?

 

Any help on doing this update would be appreciated.  Thanks



#2 requinix

requinix

    Playful Member

  • Moderators
  • 5,744 posts
  • LocationWA

Posted 31 July 2013 - 12:23 PM

I noticed that I was still using PHP 5.3.19 and 'password_compat' requires 5.3.7....

...

5.3.19 > 5.3.7

#3 jaykappy

jaykappy

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts

Posted 31 July 2013 - 01:46 PM

oh yea....but is there not a version 5.5 that I can upgrade to? 

simply update through IIS PHP manager? 

WIll if cause issues with current projects?



#4 requinix

requinix

    Playful Member

  • Moderators
  • 5,744 posts
  • LocationWA

Posted 31 July 2013 - 03:20 PM   Best Answer

I see a 5.5.1 in the downloads page so yes, there is a version there you can upgrade to. But you know you don't have to upgrade at all, right?

By the way, unless you're ready to spend the time testing your website in 5.5 and know that you'll be able to host it in a place that supports 5.5, stick with 5.3 or 5.4 for now.

#5 jaykappy

jaykappy

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts

Posted 01 August 2013 - 07:50 AM

Thanks....reason i was talking about updating my version was:  I am trying to implement 'password_compat' to hash passwords and with my current version i think i need the below mentioned php file...not sure how to install that, or get that going...

1. put the file somewhere?

2. reference it in phpl.ini?

 

Can you shed some light on that?

 

There is a compatibility pack available for PHP versions 5.3.7 and later, so you don't have to wait on version 5.5 for using this function. It comes in form of a single php file:
https://github.com/i...password_compat



#6 trq

trq

    Advanced Member

  • Administrators
  • 30,723 posts
  • LocationSydney, Australia.

Posted 01 August 2013 - 08:37 AM

What part of the installation instruction do you not understand? Its a single file.

http://thorpesystems.com | http://proemframework.org | http://github.com/trq

SmtpCatcher - A very simple mock sendmail useful for testing PHP mail scripts.
OPM - My Linux package manager.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cheap Linux VPS from $5
SSD Storage, 30 day Guarantee
1 TB of BW, 100% Network Uptime

AlphaBit.com