Jump to content

killmasta93

New Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About killmasta93

  • Rank
    Newbie
  1. killmasta93

    issue with ODBC connecting to MSSQL PHP?

    Bump anyone?
  2. Hi, I was wondering if someone could lend me a hand on the issue im having. We currently have an internal web for our users. The website was created by another person using PHP and that person we cannot reach them. The website was hosted using XAMPP on a windows server using ODBC to connect to a windows sql server for that database. Currently I migrated the htdocs to a ubuntu Server 14.04 running NGINX with php5. I installed the current packages and i was succefuly able to connect to the database (see picture) My issue is on the website when i put the username and password it should authenticate to the db of windows but instead it gives me this error on the NGINX log PHP Warning: odbc_connect(): SQL error: [unixODBC][FreeTDS][SQL Server]Unable to connect to data source, SQL state S1000 in SQ LConnect this is my odbc.ini [MSSQL] Description = MS SQL Server Driver=/usr/lib/x86_64-linux-gnu/odbc/libtdsodbc.so Server = 192.168.1.152 UID = intranet PWD = mypassword ReadOnly = No Port = 1433 this is my freetds.conf # A typical Microsoft server [MSSQL] host = 192.168.1.152 port = 1433 tds version = 8.0 initial block size = 512 this is my odbcinst.ini [FreeTDS] Description = FreeTDS driver Driver=/usr/lib/x86_64-linux-gnu/odbc/libtdsodbc.so Setup=/usr/lib/x86_64-linux-gnu/odbc/libtdsS.so FileUsage = 1 UsageCount = 1 this is my NGNIX CONF # You may add here your # server { # ... # } # statements for each of your virtual hosts to this file ## # You should look at the following URL's in order to grasp a solid understanding # of Nginx configuration files in order to fully unleash the power of Nginx. # http://wiki.nginx.org/Pitfalls # http://wiki.nginx.org/QuickStart # http://wiki.nginx.org/Configuration # # Generally, you will want to move this file somewhere, and start with a clean # file but keep this around for reference. Or just disable in sites-enabled. # # Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples. ## server { listen 80 default_server; listen [::]:80 default_server ipv6only=on; root /var/www/html/xampp/htdocs/; index index.html index.htm index.php index2.php; # Make site accessible from http://localhost/ server_name 192.168.1.3; location / { try_files $uri $uri/ /index.php?$args; # First attempt to serve request as file, then # as directory, then fall back to displaying a 404. #try_files $uri $uri/ =404; # Uncomment to enable naxsi on this location # include /etc/nginx/naxsi.rules } # Only for nginx-naxsi used with nginx-naxsi-ui : process denied requests #location /RequestDenied { # proxy_pass http://127.0.0.1:8080; #} #error_page 404 /404.html; # redirect server error pages to the static page /50x.html # #error_page 500 502 503 504 /50x.html; #location = /50x.html { # root /usr/share/nginx/html; #} # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000 # location ~ \.php$ { # fastcgi_split_path_info ^(.+\.php)(/.+)$; # # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini # # # With php5-cgi alone: # fastcgi_pass 127.0.0.1:9000; # # With php5-fpm: fastcgi_pass unix:/var/run/php5-fpm.sock; fastcgi_index index.php; include fastcgi_params; } # deny access to .htaccess files, if Apache's document root # concurs with nginx's one # #location ~ /\.ht { # deny all; #} } # another virtual host using mix of IP-, name-, and port-based configuration # #server { # listen 8000; # listen somename:8080; # server_name somename alias another.alias; # root html; # index index.html index.htm; # # location / { # try_files $uri $uri/ =404; # } #} # HTTPS server # #server { # listen 443; # server_name localhost; # # root html; # index index.html index.htm; # # ssl on; # ssl_certificate cert.pem; # ssl_certificate_key cert.key; # # ssl_session_timeout 5m; # # ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2; # ssl_ciphers "HIGH:!aNULL:!MD5 or HIGH:!aNULL:!MD5:!3DES"; # ssl_prefer_server_ciphers on; # # location / { # try_files $uri $uri/ =404; # } #} This is my index2.php which is the front page <html> <head> <title>Intranet</title> </head> <?php require_once('barras.php'); $seguir=true; if (isset($B1)) { if ($B1=="Entrar") { $rs= odbc_exec($conexion,"select nombre,nivel,seccion,cargo from tblpersonal where usuario='$usuario' and clave='$clave'"); if (odbc_fetch_row($rs)) { $nivel=odbc_result($rs,"nivel"); $nombre=odbc_result($rs,"nombre"); $seccion=odbc_result($rs,"seccion"); $cargo=odbc_result($rs,"cargo"); $_SESSION["nivel"] = $nivel; $_SESSION["usuario"] = $usuario; $_SESSION["nombre"] = $nombre; $_SESSION['seccion'] = $seccion; $_SESSION['cargof'] = $cargo; echo "<frameset framespacing=\"0\" border=\"1\" frameborder=\"1\" rows=\"90,*\"> <frame name=\"superiord\" target=\"izquierdo\" src=\"menusup.htm\" scrolling=\"auto\" > <frameset framespacing=\"0\" border=\"1\" frameborder=\"1\" cols=\"220,*\"> <frame name=\"izquierdo\" scrolling=\"auto\" noresize target=\"principal\" src=\"inicial.htm\"> <frame name=\"principal\" src=\"titulo.htm\" marginwidth=\"1\" marginheight=\"1\" scrolling=\"auto\"> </frameset> <noframes> <body> <p>Esta pĆ”gina usa marcos, pero su explorador no los admite.</p> </body> </noframes> </frameset>"; } else { echo "<body link=\"#FFFFFF\" alink=\"#FFFFFF\" text=\"#FFFFFF\" bgcolor=\"#003366\" style=\"font-family: Arial\"> <p><center><h2>Clave Incorrecta</center></h2></p> </body>"; } } else { //$nivel=$_SESSION['nivel']; } } else { echo "<body link=\"#FFFFFF\" alink=\"#FFFFFF\" text=\"#FFFFFF\" bgcolor=\"#003366\" style=\"font-family: Arial\"> <p><center><h2>Debe realizar la AutenticaciĆ³n de Seguridad</center></h2></p> </body>"; } ?> </html> and lastly the barras.php in which the index2 connect to php when then the barras.php tries to authenticate with the odbc <?php # FileName="Connection_php_mysql.htm" # Type="MSSQL" # HTTP="true" $hostname_barras = "192.168.1.152"; $connection = odbc_connect("MSSQL","intranet","mypassword"); ?> Thank you
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.