Jump to content

Archived

This topic is now archived and is closed to further replies.

lobotommy

subdomains with apache

Recommended Posts

Hi,

 

I\'m running an apache webserver on SUSE.

My domainname is linked to the nameservers of no-ip.com.

I have wildcards enabled, so *.mydomain.tld goes via a webdirect to my webserver 192.168.0.2 (via portforwarding on my firewall)

 

Now I want to server name based virtual hosts on the apache but I CANNOT find the right info in the apache manuals

 

ex: mydomain.tld has docroot /www/htdocs/main

sub1.mydomain.tld has docroot /www/htdocs/sub1

sub2.mydomain.tld has docroot /www/htdocs/sub2

 

I tried the following virtualhosts setup:

 

<VirtualHost *>

DocRoot /www/htdocs/main

ServerName mydomain.tld

</VirtualHost>

<VirtualHost *>

DocRoot /www/htdocs/sub1

ServerName sub1.mydomain.tld

</VirtualHost>

<VirtualHost *>

DocRoot /www/htdocs/sub2

ServerName sub2.mydomain.tld

</VirtualHost>

 

Whatever url I type in, I always get connected to the domain mydomain.tld (so the index file in /www/htdocs/main)

 

 

I would greatly appreciate if someone could help me out here!

 

Many thanks,

Tommy

Share this post


Link to post
Share on other sites

no-ip.com sends all the requests to my webserver

It\'s apache that should deal with the request, but it doesn\'t :cry:

 

 

Tommy

Share this post


Link to post
Share on other sites

Just a thought, but do you have the right syntax in there?

According to the Apache docs, it should be:

   NameVirtualHost *

 

   <VirtualHost *>

   ServerName www.domain.tld

   DocumentRoot /www/domain

   </VirtualHost>

whereas you have:

<VirtualHost *>  

DocRoot /www/htdocs/sub1  

ServerName sub1.mydomain.tld  

</VirtualHost>

I don\'t know if you have \"DocumentRoot\" in full in your httpd.conf?

 

D

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.