Jump to content

[SOLVED] pg_dump error


ghe

Recommended Posts

Good Day to All,

 

Hi, does anyone here know about why this pg_dump error occurs everytime I try to backup my DB?

 

> pg_dump: [tar archiver] actual file length (256661) does not match expected (253952)

> pg_dump: *** aborted because of error

>

> Process returned exit code 1.

 

I already have tried to VACUUM my DB but the error still occurs.

 

Hope to have some help.

 

Thank you in advance.

Link to comment
Share on other sites

Which version of postgres do you have?  Google search shows that older versions of postgres could fail when making a tar pg_dump, because they needed to store the uncompressed table dump in /tmp.

Link to comment
Share on other sites

For those who still experience this error in pg_dump.

 

I've fixed this problem through upgrading the version of my pgAdmin III, from v1.6.3 to v1.8.

 

Regards,

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.