Jump to content


Photo

DreamweaverMX force Design Mode


  • Please log in to reply
2 replies to this topic

#1 michaelrosejr

michaelrosejr
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 19 September 2003 - 05:41 AM

I\'ve been using DreamweaverMX for a few days now (upgraded from Homesite 5 and Ultradev4) and there\'s DreamweaverMX is annoying me. For some reason, it forces all non-html pages to be only edited via Code Mode. I would like to edit some pages that are using the .php extension in Design mode but DreamweaverMX only allows Code View. Does anyone know how to make DreamweaverMX load .php files in Design mode?

Thanks

Michael

#2 pauper_i

pauper_i
  • Members
  • PipPipPip
  • Advanced Member
  • 59 posts
  • LocationPhoenix, AZ, USA

Posted 21 September 2003 - 07:15 AM

Did you define both the local and remote folders for the website?
My setup allows me to see the html portions of the php files as html - it just doesn\'t resolve the php code properly though.

Can anyone else improve on this? I tried setting up a testbed site on my local server to test pages before uploading, but I can\'t see how I\'m supposed to update the pages on the test server either - the manula doesn\'t go into much detail on it.

D
Genius is one percent inspiration, and ninety-nine percent perspiration. [br]Thomas Alva Edison

#3 stars75238

stars75238
  • New Members
  • Pip
  • Newbie
  • 5 posts
  • LocationAddison

Posted 22 September 2003 - 07:14 PM

A few things, you are correct that DWMX renders the HTML correctly, and if you want to render the .php code then you need to select the Live Data View option (has a lightening bolt on it). This will properly render the php code assuming you do not have anything on the page that uses a $_POST/$_GET or similar variable, unless you are working on the remote file.

I have found that if you set the site up as a php/mysql server model, it will allow you to acces both the code and design views interchangebly.

Hope this helps.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users