Jump to content

Archived

This topic is now archived and is closed to further replies.

mikespad

Blank home page

Recommended Posts

On the homepage of my site [a href=\"http://Entertainmentfans.com/\" target=\"_blank\"]http://Entertainmentfans.com/[/a] sometimes shows up blank. The index.php page ALWAYS shows, at [a href=\"http://EntertainmentFans.com/index.php\" target=\"_blank\"]http://EntertainmentFans.com/index.php[/a] but obviously a lot of visitors dont type in the index.php part [img src=\"style_emoticons/[#EMO_DIR#]/wink.gif\" style=\"vertical-align:middle\" emoid=\":wink:\" border=\"0\" alt=\"wink.gif\" /]

I can not debug when or why it goes blank sometimes, and it might not be doing it for you at all, however i have checked on 2 computers thus far, and receive the blank page on both every so often.

In between that page going blank and showing, there are NO code changes going on.

This is the source of the page when its blank
---------
<html><body></body></html>
---------

Thank you so MUCH for any help you can lend.
If there are any questions i can answer please ask me :)
Mike@EntertainmentFans.com

Share this post


Link to post
Share on other sites
Hey Mike...

I'm guessing there might be a time script on your page or possible something randomising that might cause things to not be echoed properly.

Without the PHP script, It's hard to say.

One tip... link the CSS rather than writing it every single time... it makes re-branding the whole site a lot quicker.

It might be an include problem, echo problem, time or date... or just a server error. perhaps you've not deleted an index.html page or maybe your index.php has an error on it.

I saw the blank page myself and yep... it's pretty odd.

Have you turned display_errors off on your php.ini file? if so, it might be a good idea to turn it on for a short while to see it that throws anything up.. (though it'd be a good idea to turn it off again afterwards).

Good luck.

Share this post


Link to post
Share on other sites
You server may not set up to index.php as the home page. Try to add index.html with a javascript redirection
[code]
<script>
location.href="index.php";
</script>
<a href="index.php">Click Here</a>
[/code]

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.