Jump to content

Archived

This topic is now archived and is closed to further replies.

jacsmith510

mysql install error: mysqld dead but susbsys locked

Recommended Posts

Dear Forums, thanks much for this forum. I am trying a first time installation of mysql-3.23.56.1.9-i386.rpm on red hat linux 9.0. I receive an error message unable to connect to mysql.sock when I try to luanch mysql and when I check mysqld status, the error message states mysqld dead but susbsys lock. Please let me know any suggestions and thanks again

Share this post


Link to post
Share on other sites

when redhat was installed, was the prepackaged mysql installed with it? usually this happens and it is set to run at startup, so when you try to run your installed version there is a problem. if you are unsure run:

 

ps -aef | grep mysql

 

also check the hostname.err file in the mysql data directory to attempt to gain more information on the problem.

Share this post


Link to post
Share on other sites

Dear Effigy, thanks much for your post. You are correct, the mysql was prepackaged when red hat linux 9.0 was installed. When I attempted to install mysql again, the error message stated mysqld was unable to connect to mysql.sock, unable to find host.frm and when I check mysqldadmin status, the error message states:

mysqld dead but subsys locked.

I checked # ps -aef|grep mysql

the resullts were the following:

root 5761 5664 0 11:04 pts/0 00:0The local0:00 grep mysql

 

Question:

Is ther a way I can safely uninstall everything and do a fresh installl either binary 4.0 or redhat package? Please let me know any suggestions and thanks again

Share this post


Link to post
Share on other sites

Dear Effigy, thanks much for your support. I followed your suggestion, searched for all datadirs, unistalled the prior package, deleted the var/lib/mysq, var/log/mysqld.log files and the var/lock/subsys/mysql directories. I installed a binary 4.0 distribution for linux ,I unpacked the files into the usr/local/mysql, changed the persmissions, started and stopped the mysqld dameon so far without error. Thanks again for your invaluable posts and this Fourm!!

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.