Jump to content

Archived

This topic is now archived and is closed to further replies.

Rianna

$headers = 'Reply-To youremailaddress@yourISP.com' ?

Recommended Posts

Hello these instructions someone gave me to get my "From: "in my email to give my own email address as follows...

$headers = 'From: youremailstuff@yourisp.com' . "\r\n" .
'Reply-To: youremailstuff@yourisp.com' . "\r\n" .
'X-Mailer: PHP/' . phpversion();

I am doing something wrong. I am getting this error message from the server. This is what the server message says.

"MAILER-DAEMON@smtp04-02.mesa1.secureserver.net

We're sorry. There's a problem with the e-mail address(es) you're trying
to send to. Please verify the address(es) and try again."

I was told to enter my isp in the from and the reply as you can see above. I took that as meaning my server IP address. Is this incorrect? If it is the IP how to I write it, as numbers with the usual periods in between or something else.

If it isn't the IP but an ISP what exactly do you mean? Do you mean my host has its own ISP address that I can refer to? Or is there an individual ISP for each hosted account? Let me know please, thanks, Jen



Share this post


Link to post
Share on other sites
I guess the problem is not with the headers, but with the address which you are trying to send to.

As far as I know, you can mess up the headers totally and the message will still be sent.

Share this post


Link to post
Share on other sites
Thanks but it is not working anyway. My email is not sending, I am getting an error message from the server.

I need to know about this ISP question above. What do I enter into the ISP area of the command.

Share this post


Link to post
Share on other sites
[!--quoteo(post=377501:date=May 27 2006, 05:13 AM:name=1Jen)--][div class=\'quotetop\']QUOTE(1Jen @ May 27 2006, 05:13 AM) [snapback]377501[/snapback][/div][div class=\'quotemain\'][!--quotec--]
Thanks but it is not working anyway. My email is not sending, I am getting an error message from the server.

I need to know about this ISP question above. What do I enter into the ISP area of the command.
[/quote]

php.ini set the email up of your isp ok.

Share this post


Link to post
Share on other sites
??? Are you saying I need to set it up through the php ini? If so how? Thanks.


[!--quoteo(post=377523:date=May 27 2006, 03:22 AM:name=redarrow)--][div class=\'quotetop\']QUOTE(redarrow @ May 27 2006, 03:22 AM) [snapback]377523[/snapback][/div][div class=\'quotemain\'][!--quotec--]
php.ini set the email up of your isp ok.
[/quote]

Share this post


Link to post
Share on other sites
[!--quoteo(post=377524:date=May 27 2006, 08:26 AM:name=1Jen)--][div class=\'quotetop\']QUOTE(1Jen @ May 27 2006, 08:26 AM) [snapback]377524[/snapback][/div][div class=\'quotemain\'][!--quotec--]
??? Are you saying I need to set it up through the php ini? If so how? Thanks.
[/quote]
you can have an smtp service running on the server

then in the php.ini set under [mail function]

SMTP = localhost;your smtp server, localhost should be fine if the smtp server is on this computer
smtp_port = 25; or your mail port youre using
sendmail_from= user@domain; should be a user on the machine, i have mne set to webmaster and all mail sent from the mail function appears to come from webmaster at domain



from a php.ini file ok example.

sendmail_from testaddress@example.com testaddress@example.com
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25


Share this post


Link to post
Share on other sites
Or you could use a ready made mailer class that does all the header work for you.

[a href=\"http://www.swiftmailer.org/\" target=\"_blank\"]http://www.swiftmailer.org/[/a]

You can use sendmail or an SMTP server (one of your choice) with that.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.