Jump to content

Archived

This topic is now archived and is closed to further replies.

hanhao

problem with exec command executing the program in the background

Recommended Posts

i am running xampp on my computer from apachefriends.org, it's a apache server

this is the php script

<html>
<head>
<?php

exec ('notepad');
?>
</head>
</html>

but when i execute the php script on my computer , notepad doesnt not run

i used a process viewer and discovered that notepad is running in the background and i cannot see it

does anyone know how NOT to make it run in the background? i wan to see the notepad window on the apache server (my computer)

Share this post


Link to post
Share on other sites
I have no idea if notepad is a service, but, go into the services manager (from the administrative tools in control panel) and be sure the service is set up to be able to interact with the desktop.

If apache is logged on to the same account as you are, it should work

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.