Jump to content

Archived

This topic is now archived and is closed to further replies.

Phlame

God... It wont start.

Recommended Posts

Ok, I had it running once. THen after like 2 weeks of uptime I turned it off for some maintnece (I run windows XP, Apache 1.3).

 

Now, mysqld opens (the little black commandpromt looking thing) and then it closes like 2 seconds after...

If I run winsqladmin, it can\'t connect to the server...

If I goto my services...I cant start mysql cuz it can\'t connect to the server.

---

Yes, Ive tried running the other servers... like mysql-nt.. and so on.

Yes, I have tried re-installing it.

Yes, I have almost pulled my hair out because I think I am going to flip out.

---

If people on this board can help me finnally fix this... god, I will even donate to this board.

 

I went into the error file... and this is the first one I recived ... the first time it wouldn\'t run.

 

030131  6:35:40  MySql: Table \'mysql.host\' doesn\'t exist

Cannot initialize InnoDB as \'innodb_data_file_path\' is not set.

If you do not want to use transactional InnoDB tables, add a line

skip-innodb

to the [mysqld] section of init parameters in your my.cnf

or my.ini. If you want to use InnoDB tables, add to the [mysqld]

section, for example,

innodb_data_file_path = ibdata1:10M:autoextend

But to get good performance you should adjust for your hardware

the InnoDB startup options listed in section 2 athttp://www.innodb.com/ibman.html

 

pls... whats wrong? What should I do?

Share this post


Link to post
Share on other sites

it looks like a table that is necessary for the server to run is missing, in the db \'mysql\', the table \'host\' is missing, either removed on purpose or accidentally. if you want, email me at darkobject@yahoo.com and I\'ll give you the structure of my mysql.host table, if you can somehow manually enter it into the db.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.