Jump to content


Photo

IE browser overriding 404 error page...


  • Please log in to reply
4 replies to this topic

#1 ericbaze

ericbaze
  • New Members
  • Pip
  • Newbie
  • 3 posts
  • LocationCarrollton, TX

Posted 14 October 2003 - 06:17 PM

My web site/server is using a custom 404 page written in PHP/HTML (error.php); however, I\'m running into a problem with Internet Explorer.

Apparently, there is a default setting for IE where \"Friendly HTTP Error Messages\" is set. This replaces the server\'s error messages with it\'s own version. As this is a default browser setting and 85% of our site viewers are using IE, this setting presents a problem.

According to the Microsoft web site (http://www.microsoft...re/iierrcst.htm), any error file larger than 512 bytes should override this setting and display the error page.

Our error.php file is much larger than 512 bytes; however, it doesn\'t override the default IE setting. As this posted \"fix\" was probably intended to solve the problem on a Microsoft 2000 server, I appear to be out of luck on our Apache server.

I, my IT department, and the support staff of our web host have all researched the issue and been unable to come up with an answer.

Also, please note the following:

1) When I tested it, the custom 404 page appeared in multiple Netscape versions and on Safari (which I use at home).

2) With \"friendly error messages\" turned off in IE, my custom 404 page appears as expected. Unfortunately, this option defaults to \"on\" when installing and using IE.

3) When using the default 404 for my server, I achieve the same results as mentioned in #1 and #2.


Does anyone have any suggestions on how I can fix this? Obviously under the circumstances, I\'m in-between a rock and a hard place.

Any ideas are appreciated!

Thanks,


Eric Baze, Creative Specialist
ConferenceCall.com
ebaze@conferencecall.com

#2 pauper_i

pauper_i
  • Members
  • PipPipPip
  • Advanced Member
  • 59 posts
  • LocationPhoenix, AZ, USA

Posted 15 October 2003 - 01:57 AM

No guarantees on this one, but it may help.
Since you are in an intranet environment, grab a copy of the Internet Explorer Administration Kit (IEAK) 6 SP1 and redeploy IE to your users with customised settings.
This should allow you to turn the darn bug OFF before you roll it out.

Just an idea - overkill perhaps, but I assume you\'re using some form of centralised software deployment so it shouldn\'t be a major problem to do.

D
Genius is one percent inspiration, and ninety-nine percent perspiration. [br]Thomas Alva Edison

#3 ericbaze

ericbaze
  • New Members
  • Pip
  • Newbie
  • 3 posts
  • LocationCarrollton, TX

Posted 15 October 2003 - 12:47 PM

Thanks for your response. Unfortunately, it\'s our main company website (www.conferencecall.com) that\'s causing the problem -- it\'s our current and potential customers who won\'t see the error page with their IE set to defaults.

If it were an internal problem, then your solution would be perfect. I don\'t think that there\'s a client-based solution to this, but I could be wrong. Can you think of anything on ther server or within the error page that I could change?

Thanks,

Eric

#4 LAMP

LAMP
  • Members
  • PipPip
  • Member
  • 21 posts
  • LocationMissouri, USA

Posted 22 October 2003 - 06:13 AM

You might use header() to try telling your custom page to send a 200 header instead of a 404 ... quick \'n dirty, but might work??? :twisted:
Hope this sheds some light, [br]LAMP [br]******************************* [br]Warning: main(): Failed opening \'sig.php\' for inclusion (include_path=\'.:/usr/local/share/pear\') in /usr/local/www/data/phpfreaks/forums/topic.php on line 435

#5 ericbaze

ericbaze
  • New Members
  • Pip
  • Newbie
  • 3 posts
  • LocationCarrollton, TX

Posted 22 October 2003 - 01:38 PM

Thanks for your response.

How would I implement the header(); command, since this is a 404 error redirect performed by the Apache software rather than the PHP software?

Thanks,

Eric




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users