Jump to content

Archived

This topic is now archived and is closed to further replies.

flandercan

phpmyadmin problem

Recommended Posts

Hi folks,

 

I have made a backup of a freinds sql database from the phpmyadmin console. He doesnt have a shell access at all as its a hosted server, when i try to upload or restore the data i get the following error

 

Fatal error: Maximum execution time of 300 seconds exceeded in /usr/local/cpanel/base/3rdparty/phpMyAdmin/libraries/read_dump.lib.php

 

 

From what i have read its because the backup.sql file is to big and some articles have advised to chop the file up and upload in chinks, well my question is,

 

can i just chop the file up or does the file need header information at the top of each file..... or is there a better way???

 

thanks

 

Paul

Share this post


Link to post
Share on other sites

Back up table by table may solution for this.

 

However this is not always fit.

Try \"MySQL Commander\" include BiGtable feature which allow to backup huge db.

Share this post


Link to post
Share on other sites

The guy has dropped his old server so we no longer have access to the db other than the huge backup......

 

 

thanks

paul

Share this post


Link to post
Share on other sites

I tried a few things and this worked,

 

I split the file into 500k chunks by line although it takes some time to import them it does work the command i used was

 

split --line-bytes=500k backup.sql file_.sql

 

 

thanks

paul

Share this post


Link to post
Share on other sites

You might want to try this

 

set_time_limit ( int seconds)

 

 

Set the number of seconds a script is allowed to run. If this is reached, the script returns a fatal error. The default limit is 30 seconds or, if it exists, the max_execution_time value defined in the php.ini. If seconds is set to zero, no time limit is imposed.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.