Jump to content

'or die' triggered after successful INSERT


hill79

Recommended Posts

I'm getting a weird problem with a fairly simple script, see the code example below...

 

$query = "INSERT INTO firststandard.dbo.companies (company_name, business_activity, legal_status, ltd_regno, address_number, address_street, address_district, address_town, address_country, address_postcode, dataprotect_reg) VALUES ('".$company_name."', '".$business_activity."', '".$legal_status."', '".$ltd_regno."', '".$address_number."', '".$address_street."', '".$address_district."', '".$address_town."', '".$address_country."', '".$address_postcode."', '".$dataprotect_reg."')";
$result = mssql_query($query) or die("Couldn't perform $query");

 

The insert works, the data IS going in to the table as it should do, but every time I run the script the 'or die' is triggered.  I've tried using mssql_last_message() but nothing is returned which suggests there was no message.

 

I've used the same code structure to perform MySQL queries (with the obvious mysql_query() rather than mssql_query()) without issue, so why is the die kicking in?  ???

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.