Jump to content

Vista bug


Recommended Posts

Hey, I was wondering if you can help me!


I just bought a brand new vista laptop. Everything seemed to work until just now... I can't edit html files. I open an html file in notepad and do ctrl -> s (to save it) and an error message pops up. It says it's an invalid file name/path, but this isn't true. I did some research and people say it's some "read-only" bug in vista... I don't get it though. I have php/css files in those folders too, and I can edit and save them just fine.


Any ideas how I can fix this? I'll have to return my computer if i can't edit my html files... I mean it's a simple task that doesn't require much power...  :-[

Link to comment
Share on other sites

I am on vista, and I cannot edit with notpad, it tells me to check the file path to make sure the file still exists.  I downloaded notepad++, and it works fine.  I cannot find anything to solve this as well, all I can find is read only has been an issue since windows XP came out.  but that is folders, not files, so not sure what is going on either.  I am on home premium, so maybee that is the issue.

Link to comment
Share on other sites

Nope. Downloading and installing notepad++ did not help! The error I get in notepad++ is "Check that no other program is using this file" ... that's the same error I got earlier.


I don't understand why this is happening. All the files say they are "read-only" but I never made them to be "read-only." I can also edit php/css files that are read-only without a problem. At the same time some files aren't affected by this! It's really random. Microsoft has yet again showcased their incompetence.

Link to comment
Share on other sites

I hate to sound like some brainless tech from the Weak Squad, but maybe you have a virus of some sort messing with you?  Maybe your hard drive is dieing and not accessing files properly?  Just some ideas...


Yeah, you're probably right. I'm going to light a fire up under customer service's ass tomorrow. Selling me a $1700 laptop that can't do something as simple as edit html files. WTF? Vista's crap.  :-X

Link to comment
Share on other sites



Thank the lord for google! After hours of searching I found the answer. I always right click on the file and through explorer choose to "edit with notepad" ... but it doesn't let you save it when you still have it selected in the explorer. Solution: after openning notepad to edit it, click away from the file in explorer and boom it works. Personally, that is the stupidest thing I ever heard of. Microsoft just went to a new low.

Link to comment
Share on other sites

"Bla bla Vista sucks"




"Ooops, it was just me who screwed up"


lol it often goes like this...

however in this case, if the details are exactly as described, this really is a pretty silly bug for Vista to have. Shame, cos otherwise I rather like it.

Link to comment
Share on other sites

Oh c..p.

And I've spent half an hour trying to figure out how to edit my hosts file, cos it was giving me same error...

I went through all the file access privileges and all... just to find out I can overwrite it with another file, which confused me even more...


Pretty silly undocumented feature if you ask me.

Link to comment
Share on other sites

No it sounds like the problem is that you are trying to access a file with 2 different programs at the same time: the file explorer and notepad.  Windows has always been like that.  Files can only be accessed and written to by one program at a time. 


I think if there's any kind of bug, it's that the file explorer is not releasing the file...which may or may not be considered a bug, depending on how you look at it.  I mean, on the one hand, you're clearly using the file explorer to find the file and rightclick > edit, and clearly from there you don't care about file explorer; you've moved onto notepad.  But as far as windows is concerned, you still have that file selected, so how is it supposed to know you're through with it there? As far as windows is concerned, you still want to do something with that file in file explorer. 

Link to comment
Share on other sites

To me it just sounds like the user is used to run Windows XP as an admin. Then when you use Vista you can't just edit files directly because you have to run a program with elevated permissions in order to edit system files. Therefore it gives that error. Kind of like trying to edit /etc/hosts on GNU/Linux without being root. It's just the user that's used to bad habits.


When you installed Apache you did it in admin mode so that means the ACL hasn't got entries for your user which means you cannot edit httpd.conf in an unprivileged way. Likewise is it the same for the hosts file which Mchl mentioned above.


It's neither silly nor undocumented and it's definitely not a bug. It's just different from XP.

Link to comment
Share on other sites

I tried editing my fhosts file using admin privileges. I even gave a public access to it, so in theory everyone should be able to edit it. Still nothing.

Then I just make a copy of it. Edit it elsewhere, and then overwrite it back and it works... And UAC is not even asking me to do it as administrator. If I don't have privileges to edit it, how come I have privileges to overwrite it?

It's not only different from XP, but from any other OS I know.

Link to comment
Share on other sites

It's exactly the same as GNU/Linux:


daniel@degeberg:~$ echo 'hi' >> /etc/hosts
-sh: /etc/hosts: Permission denied
daniel@degeberg:~$ sudo -i
[root@degeberg ~]# echo 'hi' >> /etc/hosts
[root@degeberg ~]#


In Vista's GUI using Notepad this corresponds to:

1) Open Notepad normally. Browse to and open C:\Windows\System32\drivers\etc\hosts

2) Edit something

3) Save


This will give you this error:

Cannot create the file C:\Windows\System32\drivers\etc\hosts file.


Make sure that the path and file name are correct.


Then do this:

1) Right click on the Notepad icon

2) Select "Run as administrator"

3) Browse to and open C:\Windows\System32\drivers\etc\hosts

4) Edit something

5) Save


Then it will save successfully.


Quod erat demonstrandum.

Link to comment
Share on other sites

This thread is more than a year old. Please don't revive it unless you have something important to add.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.