Jump to content

Archived

This topic is now archived and is closed to further replies.

jakeyjake

apache2 is not parsing unless the .php extension is included

Recommended Posts

I have recently update from apache 1 to apache 2. It used to be the case that i could just type in the file name such as http://localhost/index and it would recognise that the index file was php (or any other file) and parse it. Now however i have to make sure i type the file extension so that the file will be parsed such as http://localhost/index.php this is a rather annoying situation.

 

I have updated httpd.conf with:

AddType application/x-httpd-php .php

and

LoadModule ....

 

can someone point me in the right direction???

 

Ta :D

Share this post


Link to post
Share on other sites

Did you update the directory index:

DirectoryIndex index.php index.html index.html.var

?

Share this post


Link to post
Share on other sites

yer mate... all changed... i really have no idea whats going on... its not really a massive problem.... maybe its better in terms of security but i just got used to it with apache 1.3.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.