Jump to content

Archived

This topic is now archived and is closed to further replies.

anatak

**SOLVED** easyphp

Recommended Posts

Hello I am trying to export a table from my home pc to the server.
export using easyphp creates this
[code]

DROP TABLE IF EXISTS `about`;
CREATE TABLE `about` (
  `AboutId` int(11) NOT NULL auto_increment,
  `AboutAuthor` int(11) NOT NULL default '0',
  `AboutTitle` varchar(255) default NULL,
  `AboutText` text,
  `AboutUpdateDate` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
  `AboutPostDate` timestamp NOT NULL default '0000-00-00 00:00:00',
  `AboutHide` tinyint(4) default '1',
  PRIMARY KEY  (`AboutId`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=2;

[/code]

this results in the following error

MySQL said:
#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
 `AboutPostDat

can anyone point me what the correct syntax would be ?

I think this is because of different versions fo MySQL
home computer uses 4.1.9 max
server version is 4.0.23 standard

regards
anatak

Share this post


Link to post
Share on other sites


Removing this: "default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP" should set things right.

That syntax was added in MySQL 4.1.2.

Share this post


Link to post
Share on other sites
Thanks for the reply.

My hosting firm will change my account to a MySQL 5 Server so I guess I will just wait untill that is done.

kind regards
anatak

Share this post


Link to post
Share on other sites
i have problem with PHP (im noob just starting to make something...so please STEP BY STEP)
i installed easyphp and i use phpmyadmin for install phpnuke...now when i enter phpmyadmin i have databes named phpnuke(94) and i have all tables installed no errors... anyway wut do do next when i try run http://localhost/phpnuke/html/  all i get is this notes...
"

Notice: Undefined index: HTTP_ACCEPT_ENCODING in c:\easyphp1-8\www\phpnuke\html\mainfile.php on line 47

Notice: import_request_variables(): No prefix specified - possible security hazard in c:\easyphp1-8\www\phpnuke\html\mainfile.php on line 64




There seems to be a problem with the MySQL server, sorry for the inconvenience.

We should be back shortly.


"


i wanna try set it on localhost for now to test it so please help me... :)  ???

Share this post


Link to post
Share on other sites
woops
sorry for the extremely late reply.
I can't help you with this.
I don't use Nuke,
did you start a topic for yourself ?
if not please do.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.