Jump to content

Archived

This topic is now archived and is closed to further replies.

lisa

php.ini directory in phpinfo is wrong

Recommended Posts

I have PHP5 running with Apache2 on XP. I've been having a hard time getting MySQL working. Then I noticed that according to phpinfo(), php.ini is in C:/windows. My php.ini file is not in C:/windows (there isn't even a php.ini file in C:/windows) it's in C:/php5. I've tried putting the file in C:/windows but it still doesn't recognize my changes. I've also added a registry variable HKEY_LOCAL_MACHINE/SOFTWARE/PHP/IniFilePath pointing to C:/php5 but I've had no luck.
Can anyone help me?

thanks,
lisa

Share this post


Link to post
Share on other sites
If you have Apache2 add this line to your httpd.conf file:
[code]PHPIniDir "C:/php5"[/code]

Once you have added that save your httpd.conf file and restart Apache.

Share this post


Link to post
Share on other sites
[!--quoteo(post=387721:date=Jun 25 2006, 06:25 AM:name=wildteen88)--][div class=\'quotetop\']QUOTE(wildteen88 @ Jun 25 2006, 06:25 AM) [snapback]387721[/snapback][/div][div class=\'quotemain\'][!--quotec--]
If you have Apache2 add this line to your httpd.conf file:
[code]PHPIniDir "C:/php5"[/code]

Once you have added that save your httpd.conf file and restart Apache.
[/quote]


I've always had that line in my httpd.conf file and I restart Apache every time I make a change to php.ini but I [i]STILL[/i] am having this issue.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.