Jump to content

Archived

This topic is now archived and is closed to further replies.

maxert

Weird Characters Appear Only In Firefox

Recommended Posts

I am getting some odd characters appearing in the beggining of an include when rendered in firefox (v 1.5x on XP Pro). The characters are: 

These are not appearing in IE6

Any ideas on what is causing this?

The include line:
[code]<?php
include_once ('rootdir/filedir/filename.php');
?>[/code]

This is not occuring for other included files. This is the last include on the page.

Include file source:
[code]</div></div>
<div id="footer">
        <div id="submenu">
        <ul>
        <li><a href="registry.php" <?php if ($thisPage=="Registry") echo " class='active' "; ?>title="Home">Registry</a></li>
        <li> - <a href="pictures.php" <?php if ($thisPage=="Pictures") echo " class='active' "; ?>title="Pictures">Pictures</a></li>
        <li> - <a href="contact.php" <?php if ($thisPage=="Contact") echo " class='active' "; ?>title="Contact Us">Contact us</a></li>
        </ul>
        <span class="clearfix"> </span>
        </div>
</div>
<script type="text/javascript">

if(typeof sIFR == "function"){
    sIFR();
};
</script>

<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "accountcode";
urchinTracker();
</script>

</body>
</html>[/code]

Any ideas?

Thanks!

Share this post


Link to post
Share on other sites
This can also be fixed by changing the following meta tag

from this:
[code]
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
[/code]
to this:
[code]
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
[/code]

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.