Jump to content

Archived

This topic is now archived and is closed to further replies.

Monshery

Challenging Problem !

Recommended Posts

Thanks for helpers or anyone.
I am trying to send a mail via php. and i dont know much about it :
i uses this code :
[code]
$to = $_POST['REMAIL'];
      $subject = "Activation details - MMODATE -";
      $message = "Congratulation \r".$_POST['RUSERNAME']." \r for signing up with MMODATE your one step from beeing an active memeber of MMODATE<BR><BR>". 'Please click on this link to activate your account <BR> <a href= "http://localhost/Yanivs/MMO-Date/Activation.PHP?USDC='.$checkbig .'&USDP='.$_POST['RPASSWORD'] .'">http://localhost/Yanivs/MMO-Date/Activation.PHP?<a>';
      $message = wordwrap($message, 70);
      $headers  = 'MIME-Version: 1.0' . "\r\n";
      $headers .= 'Content-type: text/html; charset=iso-8859-1' . "\r\n";
      $headers .= 'From: MMODATE <monshery@MMODATE.com>' . "\r\n";/* well i just used some random names here i dont know what sould i fill in here*/
      mail($to, $subject, $message, $headers);
[/code]

Well i get this error everytime i try this :
[code]
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 3306, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\Yanivs\MMO-Date\Register.PHP on line 451
[/code]

Any help would be extrmly appricated. thanks

Share this post


Link to post
Share on other sites
What this is saying is that you a) do not have an SMTP enabled machine or b) your settings for SMTP in the php.ini file are incorrect

Share this post


Link to post
Share on other sites
well you know how do i correct it ?
basicaly for a) i dont know if i have a a working machin and for 4 i set. SMTP = localhost and smtp_port =3306 which is my MYSQL server details i might be doing something wrong . you have any idea how i solve it ?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.