Jump to content


Photo

Problem coding PHP in Dreamweaver


  • Please log in to reply
4 replies to this topic

#1 ssmK

ssmK
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 01 July 2006 - 03:23 AM

I open it up and start coding a PHP file in code view, and even though auto indent is enabled, it does absolutely nothing in the way of indentation, besides the obvious check box (checked) next to Auto Indent, does anyone know how I could perhaps get this up and running?

Thanks, BTW, what are your favorite IDEs for PHP editing?



#2 shoz

shoz
  • Staff Alumni
  • Advanced Member
  • 600 posts

Posted 01 July 2006 - 04:07 AM

Thanks, BTW, what are your favorite IDEs for PHP editing?

http://www.phpfreaks...ic,54859.0.html

#3 cmgmyr

cmgmyr
  • Members
  • PipPipPip
  • Advanced Member
  • 1,278 posts
  • LocationUSA

Posted 01 July 2006 - 06:10 AM

make sure your indent preferences are set above 0, if you just installed it sometimes it defaults to 0.

I have mine set to 2 spaces

#4 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 01 July 2006 - 10:43 AM

Dreamweaver only does this with a few lanagauges, Such as Javascript and i think ASP and VBScript. It doesnt do it for all lanaguages. Also if you are coding in PHP you're best of with an IDE, which someone has already provided a link to a thread that discusses the best IDE.

#5 Daniel0

Daniel0
  • Staff Alumni
  • Advanced Member
  • 11,956 posts

Posted 08 July 2006 - 12:12 PM

Thanks, BTW, what are your favorite IDEs for PHP editing?


I would recomment Zend Studio.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users