Jump to content

Archived

This topic is now archived and is closed to further replies.

DummyNewB

index.php files don't show

Recommended Posts

I have a new Apache 2.2 server with PHP5 installed and everything works great. Except...
If I try to access a directory where the index page has a php extension (index.php) it just lists the directory contents and does not parse the php file automatically. If the extension was html or htm it works fine. If I type in the exact "directory/index.php" it works fine. It just seems that the server will not recognize any php file unless I use the exact file name.  Am I making sense?
How do I tell the server to run/open .html, .htm, .shtml and also .php?

Thanks in advance for your help.

DNB

Share this post


Link to post
Share on other sites
Open you httpd.conf file and search for the following line:
[code]DirectoryIndex index.html index.html.var[/code]
Now add a space after index.html.var and add index.php

Now save the httpd.conf file and restart Apache. index.php files should now be run automatically when in a directory.

Share this post


Link to post
Share on other sites
WOW! I looked and looked for something like that but never saw it. Must be tired. Thanks for the help. All works great now.

DNB

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.