Jump to content

Archived

This topic is now archived and is closed to further replies.

Capacitor

apache 1.3.36 and php 5.1.14 - cant get it working

Recommended Posts

This is driving me batty.
I've installed apache 1.3.36 from source and php 5.1.14
but trying to load index.php or admin.php or any .php pages just gives me text.
I tried "--with-apache" and "--with-apxs" but claim they do the work properly,
but they dont.

my httpd.conf shows- LoadModule php5_module        libexec/libphp5.so
there is NO "ClearModuleList" in my httpd.conf (grep -i clear shows no result)
and no AddType for php

if I add the AddType manually say just below the tgz handler, it still doesn't work.
I know I'm missing something insanely stupid, but I can't figure out what it is.

This is a brand new install from scratch, nothing else has been done with the files.

Share this post


Link to post
Share on other sites
I fixed it!

A completely non-obvious and counter-intuitive fix.
here's the solution (for me)-

the following two lines:
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
MUST be added IMMEDIATELY after the LoadModule line for php

augh!

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.