Jump to content

CSS fails on php page when $_GET data used in URL


fj1200
 Share

Recommended Posts

Title says it all really.  CSS works fine when I use the page url on it's own - ok so I've got no data but I'm just making a working page look pretty and so it looks the same as all my other pages.  .

 

However, it's called as a link from a list of jobs in a parent page pulled from a DB query, and when I run it from there - clicking the link - I get all the data but no css formatting.  Same results in any browser.  I already have a very similar page that works perfectly with the same css sheet and I can't see any differences.  All the quotes are there, all the ;'s and ()'s are there.  The only thing I can think of is that with the GET data it thinks it's looking for a different page?  Probably talking rubbish here though.

 

Anyone able to help?

Link to comment
Share on other sites

Links in the <head> section.

 

 <link rel="stylesheet" href="css/form.css" type="text/css">

 

Works perfectly in other pages with near-identical content.

 

 

Chances are it is because you need the full path inside the href.

 

IE:

 <link rel="stylesheet" href="http://yoursite.com/css/form.css" type="text/css">

Link to comment
Share on other sites

This thread is more than a year old. Are you sure you have something important to add to it?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.