Jump to content

Archived

This topic is now archived and is closed to further replies.

Carter McArthur

A problem with php install

Recommended Posts

I had a problem with my php5 installation so I dumped it's files. The reason was because I could not get the code to process correctly. When html code was parsed, it would respond,but when php parsed it would not read the $_post info.
Now since I reinstalled the php after a clean install.
I get this response from my command prompt.

[Quote]

C:\PHP>php -t
PHP Warning: PHP Startup: dba: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
in Unknown on line 0
PHP Warning: PHP Startup: fdf: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
in Unknown on line 0
PHP Warning: PHP Startup: dbg: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
in Unknown on line 0
[/Quote]

I hope that someone can help me solve this situation.
Carter

Carter McArthur

Share this post


Link to post
Share on other sites
not being able to read _POST info could be due to your php.ini settings because there are some options where you can do things like overwrite _POSt variables.

how did you install PHP?

Share this post


Link to post
Share on other sites
Hi Koobi,

  I downloaded it from php.net. I followed the instructions given on one the forums also. Since then I have gone back to the basics and followed the instructions on how to comment out some of the extensions but I fell in to more trouble because now my php is showing errors where there was none before. I now have commented out every extension in the php ini file but I still get errors parsing simple scripts now. I even tested with
[quote]
<?php
phpinfo();
?>
[/quote]
Now I get nothing but rows of text, so I'm sitting here exhausted and need desperately to understand what went wrong other than finding out that some of my extensions like php_dbg.dll and php_dz2.dll plus some others that cause my command prompt to issue that they cannot be loaded.
  I've learned a lot but I guess it's not enough to solve my problems.

          ironfoot

Share this post


Link to post
Share on other sites
i downloaded the php.net and installed it but it shows that "None of the 2 services running"...i tried to start all services but it shows an "exception and internal error".Tried reinstalling it but with same result.my OS is Vista..Should i change it to Winxp and try..Plz help

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.