Jump to content

Archived

This topic is now archived and is closed to further replies.

abazovicMirza

How to enable gd

Recommended Posts

Suse 10
I installed apache2, apxs, mysql, ... and php4 as module also php4-gd (gd) php4-mysql etc .. all using yast
started and stoped apache2 server

but my phpinfo() shows all the time this
'./configure' '--prefix=/usr' '--datadir=/usr/share/php' '--mandir=/usr/share/man' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--sysconfdir=/etc' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-inline-optimization' '--enable-memory-limit' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sigchild' '--disable-ctype' '--disable-session' '--without-mysql' '--disable-cli' '--without-pear' '--with-openssl' '--with-apxs2=/usr/sbin/apxs2-prefork' 'i586-suse-linux'

note '--without-mysql'  but mysql support works

Server API Apache 2.0 Handler

I have error log from apache Unable to load dynamic library '/usr/lib/php/extensions/gd.s' ...  undefined symbol gdImagePngCtx in Unknown

Please
I want to enable gd I have all packages installed and restarted server and I think that problem is in
Unable to load dynamic library '/usr/lib/php/extensions/gd.s' ...  undefined symbol gdImagePngCtx in Unknown
How to solve this

Share this post


Link to post
Share on other sites
Add something like: [code]extension=gd.so[/code] in your php.ini file if you use Linux, else I think it's [code]extension=php_gd.dll[/code] or something like that.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.