Jump to content


Photo

A very messy PEAR


  • Please log in to reply
1 reply to this topic

#1 scottybwoy

scottybwoy
  • Members
  • PipPipPip
  • Advanced Member
  • 532 posts
  • LocationUK

Posted 07 July 2006 - 01:07 PM

Hi All,

I've installed pear into my web server's (IIS4.5) wwwroot.  Now there are files all over the place.  I went into the PEAR management page and changed the locations to ~wwwroot/PEAR/whateverDir and before commiting the changes, physically moved the folders there.  After commiting it did not like the changes due to a pearsys.ini problem, not that I could find this "pearsys.ini" anywhere.  However located a pear.ini, also cluttering up my web server directory.

I opened up this file and edited the settings directly in there. and wanted to move this file and the cunningly named index.php (which opens the PEAR manager) from my web directory into the PEAR folder.  Now I get this error :

WARNING: channel "pear.php.net" has updated its protocols, use "channel-update pear.php.net" to updatePHP Fatal error: Maximum execution time of 60 seconds exceeded in c:\Inetpub\wwwroot\PEAR\PEAR\REST.php on line 359 PHP Fatal error: Maximum execution time of 60 seconds exceeded in c:\Inetpub\wwwroot\PEAR\PEAR.php on line 765

When using the "pear channel-update pear.php.net" in the comand prompt it doesnt recognise the command.  Is there a way I can just uninstall it and start afresh?  Or can anyone specify how I can get round this?

Thanks in advance.

#2 scottybwoy

scottybwoy
  • Members
  • PipPipPip
  • Advanced Member
  • 532 posts
  • LocationUK

Posted 07 July 2006 - 01:20 PM

Problem Solved




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users