Jump to content

[SOLVED] Setting up Zend Framework with Smarty


Recommended Posts

Alright, it'll work perfectly the way I did it so far. But I run into a problem when I try to use modules. (Which I need).


The way it's set up, I have a directory "templates". If I want to run "localhost/default/" it looks for the template inside "templates/index/". Basically, it goes for the templates/(controller)/(action)


I need it to look for templates/(module)/(controller)/(action)


Anyone know how to do that?

Link to post
Share on other sites

Nevermind, I solved it about 30 seconds after I posted this. Sorry.


I went to this file: "Zend/Controller/Action/Helper/ViewRenderer.php"


I changed this line:

protected $_viewScriptPathSpec = ':controller/:action.:suffix';

To this:

protected $_viewScriptPathSpec = ':module/:controller/:action.:suffix';


Pretty simple...

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.