Jump to content

Archived

This topic is now archived and is closed to further replies.

chris_friberg

Authentication Not Working, Possibly Not Starting (1.3 on FreeBSD)

Recommended Posts

[color=blue]I had Authentication working at one point in time.  I used httpd.conf to specify the directory I wanted password authenticated.  I decided to change that line to ask for authentication on a different directory, and now it seems to ignore that section and not ask for authentication when you access pages in this directory.  I looked through the FAQ and it only mentions basic troubleshooting of .htaccess files which I tried applying here, but with no luck.  I also scanned through the forum for solutions.

Here's the part of my httpd.conf file with Directory settings:[/color]
"
[tt]<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory /usr/local/www/data>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<Directory "/usr/local/www/data/xxx">
    AuthType Basic
    AuthName "By Invitation Only"
    AuthUserFile /etc/xxxpass
    Require user aaa bbb ccc
</Directory>[/tt]
"

[color=blue]Also, I don't know if these warnings mean anything, when I restart apache.  I get this:[/color]
"
[tt]$ apachectl restart
/usr/local/sbin/apachectl restart: httpd not running, trying to start
[Tue Jul 11 16:44:01 2006] [warn] NameVirtualHost www.mysite.com:80 has no VirtualHosts
[Tue Jul 11 16:44:01 2006] [warn] NameVirtualHost www.mysite2.com:80 has no VirtualHosts
[Tue Jul 11 16:44:01 2006] [warn] NameVirtualHost webmail.mysite.com:80 has no VirtualHosts
/usr/local/sbin/apachectl restart: httpd started[/tt]
"

[font=Verdana][font=Verdana][font=Verdana][font=Verdana][color=blue]Can someone double check my httpd.conf lines and/or interpret my warnings?

Thanks![/color][/font][/font][/font][/font]

Share this post


Link to post
Share on other sites
Looks like it isn't a problem with your directory settings, but rather with your virtual hosts.  Can you post that section of your config file also?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.