Jump to content

Archived

This topic is now archived and is closed to further replies.

foreverhex

problem with cross browsers

Recommended Posts

ok, maybe you guys can see something that I cant. Its driving me crazy. When you look at [url=http://www.syblings.net/news.php]www.syblings.net/news.php[/url] with Firefox it looks great, dandy, perfect. When you look at it in IE the top part is disjointed and funked. I cant figure out why, so maybe some one else can, thx.

Share this post


Link to post
Share on other sites
Try adding this to .top
border-collapse: collapse;

Let me know if it works.

Share this post


Link to post
Share on other sites
poop. No that didnt seemed to work. I wonder why it is all screwy? Got any other ideas? Thx for the help btw.

Share this post


Link to post
Share on other sites
one of the best practices you can get into with CSS is to have a:
[code]
* {
margin: 0;
padding: 0;
}
[/code]

as the very first assignment in your file. that forces IE to render no default margin or padding that it applies usually. the only downside to that is that YOU have to determine what every bit of spacing on your site will be. this simple adjustment often helps with layout issues between FF and IE.

Share this post


Link to post
Share on other sites
I gave that a try and nothing seemed to change. Did you want me to place that code in literally? Because thats what I did. I also checked to see if all my margins and padding were right and they all seemed to be ok. I hate IE

Share this post


Link to post
Share on other sites
I found your problem. Look at line 311:

(lines 307-319)
[code]
<td align="right" width="10" height="156">
<img src="/images/tippytopr.gif" border=0 align="right" width="10" height="156">
</td>
</tr>
</table> <--311

</td>
</tr>

<tr>

<td  valign="top" width="184" height="35">
<img src="/images/tippytop4.jpg" width="184" height="35" alt="">
[/code]
You closed the table early. Take it out and it should look better.

So I guess it's not really an Internet Explorer problem, but let's blame it on IE anyway, because it's evil.

Share this post


Link to post
Share on other sites
[quote author=johnnyk link=topic=100254.msg395816#msg395816 date=1152722517]
I found your problem. Look at line 311:

You closed the table early. Take it out and it should look better.

So I guess it's not really an Internet Explorer problem, but let's blame it on IE anyway, because it's evil.
[/quote]

actually, that's not a problem seeing that he's using embedded tables for his layout. the table is within a <td> tag, so it has to be closed there.

foreverhex, that in and of itself (what i posted above) is seldom a cure, but it does help get rid of some of the underlying descrepencies between FF and IE. you may even need to go as far as checking white space in your markup. IE often interprets white space around images with line breaks and other nonsense, too.

Share this post


Link to post
Share on other sites
Yeah i am using embeded tables with in tables. I hope that isnt a problem, because I use that alot.  Ill go through and make sure that I dont have pointless spaces and what not. Also what you cant see in the html code is that there is a php line in there, where the login form is. Do you think that could be why? its just a simple switch. It checks if the user is online if not the login menu shows (what you all seen) and if they are the cpanel options come up instead.

UPDATE: That didnt seem to work. Im thinking of redoing and analyzing it on IE then worring about it of FF. It seems to be easier to fix anything on FF than IE. Any other suggestion?

Share this post


Link to post
Share on other sites
AH! correction, i needed to refresh my history and now it looks better. That stupid IE interpreting lines worked. Thanks... but there is still a problem. The borders for the banner are spead out all dumb like. Have any ideas?

Share this post


Link to post
Share on other sites
Ok, so i fiddled around a bit and on the line
[code]<td width="10" height="156" valign="top"><img src="/images/tippytopl.gif" border=0 align=left ></td>[/code]
and removed align=left. Now everything looks perfect... makes no since but what ever. DOWN WITH IE!

Share this post


Link to post
Share on other sites
I never realized how much I hated IE until I was doing alot of CSS work. I hope IE7 is just as bad, cause if it is IE is gonna be done soon.

Share this post


Link to post
Share on other sites
yes, they've definitely gone to tabbed browsing. have you tried the beta? it's actually a decent browser (as much as i hate to say it). it's definitely much more compliant, and although it still has its quirks, it supports some of the CSS2 attributes like min-height that IE6 doesn't.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.