Jump to content


Photo

Why can't I write to files?


  • Please log in to reply
4 replies to this topic

#1 royrules22

royrules22
  • Members
  • PipPip
  • Member
  • 11 posts

Posted 12 July 2006 - 10:35 PM

This is annoying. I can't write to files when fopening them with w, w+, a or even a+. My or exit() statement is excuted instead. However when I open it via r mode it works fine. So I assume it has problems writing. But is_writeable() return true!

What in the world can be happening? This is a Windows IIS server so I cannot chmod it, and nor can I ask the admin to change it. Any solutions?

#2 karthikeyan_coder

karthikeyan_coder
  • Members
  • PipPipPip
  • Advanced Member
  • 201 posts

Posted 12 July 2006 - 11:12 PM

try to change the file permission via your control panel... i think your cp is Plesk... so try it your self... every cp is having an option for file and folder permissions...

thank you,
Karthi Keyan.
www.karthi.us

#3 ShogunWarrior

ShogunWarrior
  • Members
  • PipPipPip
  • Advanced Member
  • 528 posts
  • LocationIreland

Posted 12 July 2006 - 11:32 PM

Even though Windows has no CHMOD, it may be read-only, however since it's showing writeable, I don't know if that is possible.
<a href="http://www.daviddora...nmedia.com/">My New Site/Blog</a> | <a href="http://www.daviddora...m/check/">Check your page for broken links/images/scripts</a>

Zend Certified Engineer
Follow me on Twitter: http://twitter.com/davidd

#4 AndyB

AndyB
  • Staff Alumni
  • Advanced Member
  • 5,465 posts
  • LocationToronto

Posted 12 July 2006 - 11:35 PM

On the off-chance that it's actually a problem with your code, care to post some of it - particularly the section where writing fails through to your exit().
Legend has it that reading the manual never killed anyone.
My site

#5 royrules22

royrules22
  • Members
  • PipPip
  • Member
  • 11 posts

Posted 12 July 2006 - 11:36 PM

Thanks! It was read-only. I went into the CP (not Plesk just some other custom one). I added write permission onto that file so it works now. But I just have to figure out how to set permission to only one file rather than a directory.. Still don't know why is_writeable worked..




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users