Jump to content


Photo

MySql Connection Error


  • Please log in to reply
4 replies to this topic

#1 DrAxeman

DrAxeman
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 12 February 2003 - 08:37 PM

When ever I try to connect to my MySQL server from a remote client I get the error:

ERROR 2013: Lost connection to MySQL server during query

when I check the MySQL log it says:

Number of processes running now: 1
mysqld process hanging, pid 3131 - killed
030212 14:49:14 mysqld restarted
/usr/libexec/mysqld: ready for connections

ANY and ALL suggestions will be appreciated. I have spent FAR too much time on this.

Dr. Axeman
Linux Guru/Geek [br]Willing to help anyway I can with Linux related questions.

#2 DrAxeman

DrAxeman
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 12 February 2003 - 08:44 PM

All of this happens when:


[root@vergason phpMyAdmin-2.3.2]# mysql -u alex -h 192.168.0.203
ERROR 2013: Lost connection to MySQL server during query


(NOTE: a password is required)
Linux Guru/Geek [br]Willing to help anyway I can with Linux related questions.

#3 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 12 February 2003 - 09:47 PM

does that command ever prompt you for a password? if not, add a -p switch. you may also take a look at your my.cnf regarding timeouts - i do not know much regarding remote issues :shock:
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#4 DrAxeman

DrAxeman
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 12 February 2003 - 10:08 PM

It never asked for a password. It just kicks out the error. When I use the -p option it will ask for one, and then give the error. I can connect from the console of my MySQL server.
Linux Guru/Geek [br]Willing to help anyway I can with Linux related questions.

#5 DrAxeman

DrAxeman
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 13 February 2003 - 12:10 AM

Some versions of MySQL will crash when attempting to perform a DNS lookup. Hence it was crashing when trying to resovle alex.vergason.com... when I places the placed the following entry into the /etc/hosts file everything worked just fine.

192.168.0.77 alex.vergason.com

Strange, but a workaround none the less.

Dr. Axeman - Really a Linux Geek, wannabe MySQL geek.
Linux Guru/Geek [br]Willing to help anyway I can with Linux related questions.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users