Jump to content


Photo

base directory problem


  • Please log in to reply
4 replies to this topic

#1 cgarlick

cgarlick
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 13 July 2006 - 06:33 PM

I am haveing a problem with ./ and ../.

Both are not saying
EX:/var/www/ai/mydomain.com/web/

php acts like its just reading it as part of the directory...

like this..
EX:Warning: main(../moduels/Roster/settings.php): failed to open stream: No such file or directory

The file is in :/var/www/ai/mydomain.com/web/moduels/Roster/settings.php
and if I state this it works for that instance...

I have read a bit about open_basedir but if I try to set it with htaccess it breaks htaccess.

http://www.avatarher...hp?mode=phpinfo

Thanks for any help and let me know if you have any questions.

Claude

#2 akitchin

akitchin
  • Staff Alumni
  • Advanced Member
  • 2,516 posts
  • LocationCalgary, AB, Canada

Posted 13 July 2006 - 06:43 PM

what are you using to express the path?  single quotes will not translate the path, so maybe try using double quotes to enclose the filename/path.  either way, seeing some code might help.

#3 cgarlick

cgarlick
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 13 July 2006 - 06:59 PM

require_once( '../moduels/Roster/settings.php' );

Thats how it is looking

#4 akitchin

akitchin
  • Staff Alumni
  • Advanced Member
  • 2,516 posts
  • LocationCalgary, AB, Canada

Posted 13 July 2006 - 07:42 PM

then try using double quotes, as i'd said:

require_once( "../moduels/Roster/settings.php" );


#5 ShogunWarrior

ShogunWarrior
  • Members
  • PipPipPip
  • Advanced Member
  • 528 posts
  • LocationIreland

Posted 13 July 2006 - 07:46 PM

Are you sure "moduels" is spelt right? Should it be "modules".
<a href="http://www.daviddora...nmedia.com/">My New Site/Blog</a> | <a href="http://www.daviddora...m/check/">Check your page for broken links/images/scripts</a>

Zend Certified Engineer
Follow me on Twitter: http://twitter.com/davidd




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users