Jump to content

Archived

This topic is now archived and is closed to further replies.

marek

mail

Recommended Posts

I'm sure it's an easy one.
I can't use mail function. I get an error message: 
Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini.
But I work locally only. All I did was changing "sendmail_from = " in php.ini file.
Do I have to change smtp and smtp_port settings also? If so, what parameters should I give there?
Thanks
marek

Share this post


Link to post
Share on other sites
To use the mail function you need an smtp server. You can either get your own, or use the one of your isp.

Share this post


Link to post
Share on other sites
yo whats a smtp server? and how would u get one because my validate emails dont work on my forums -_-

Share this post


Link to post
Share on other sites
To use mail you'll need to point it to an actual SMTP server. If you dont have an SMTP installed on your local machine it will not send an email. See if you can find a public SMTP server which does require authentication in order to send an email, as mail does support this. You shouldn't have to change the port number as SMTP servers run on port 25

Share this post


Link to post
Share on other sites
Ok. So I changed SMTP settings for the same as in MS Outlook. I left smtp_port = 25. Restarted server.
Still doesn't work.

Share this post


Link to post
Share on other sites
Does the smtp server you are using require you to login? If it does you cannot use this SMTP Server as mail doesnt support authentication requests - loggin.

Share this post


Link to post
Share on other sites
Yes. My e-mail smtp server requires me to login.
So what can I do to use mail function?

Share this post


Link to post
Share on other sites
You cant use that smtp server with mail then. If you want to use that smtp server I think you'll have to use imap which allows you to login to mail servers.

Share this post


Link to post
Share on other sites
So I guess I just skip mail function for some time
thanks anyway
marek

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.