Jump to content

Archived

This topic is now archived and is closed to further replies.

russia5

Nano Editor leaves whitespace

Recommended Posts

I have always had this wierd problem with Nano.  It may be with other editors too, but I almost always use Nano.  It leaves white space when I save.  I have a problem with my config.php file in that there can be no white space after the last tag. ie) ?>  Each time I save, I get <p>nbsb</p>  I delete it and save it again and the line reapears.  Any ideas of what causes this?

Share this post


Link to post
Share on other sites
A lot of editors add extra characters to the source code. My suggestion is to use the best editor out there: Notepad :-D If would like to continue using your editor, a short fix would be to create it with Nano and then open it with notepad when your done. Once in notepad, delete that extra added tag and then save.  I know this isn't the answer you wanted, but consider it a free bump at the least.

Share this post


Link to post
Share on other sites
I always use the Code View ONLY of Dreamweaver! Works great! And visually easier than NotePad!

Just make sure to never EVER go to the Design View and try doing anything there!

Another good software (free) is TextPad (it also colour - codes just like Dreamweaver and does not add any extra characters).

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.