Jump to content


Photo

Nano Editor leaves whitespace


  • Please log in to reply
2 replies to this topic

#1 russia5

russia5
  • Members
  • PipPipPip
  • Advanced Member
  • 94 posts

Posted 19 July 2006 - 11:18 AM

I have always had this wierd problem with Nano.  It may be with other editors too, but I almost always use Nano.  It leaves white space when I save.  I have a problem with my config.php file in that there can be no white space after the last tag. ie) ?>  Each time I save, I get <p>nbsb</p>  I delete it and save it again and the line reapears.  Any ideas of what causes this?

#2 kalivos

kalivos
  • Members
  • PipPipPip
  • Advanced Member
  • 88 posts
  • LocationCalifornia

Posted 21 July 2006 - 04:58 PM

A lot of editors add extra characters to the source code. My suggestion is to use the best editor out there: Notepad :-D If would like to continue using your editor, a short fix would be to create it with Nano and then open it with notepad when your done. Once in notepad, delete that extra added tag and then save.  I know this isn't the answer you wanted, but consider it a free bump at the least.
Make a donation to phpfreaks. They need your help![br][br]

#3 yana

yana
  • Members
  • PipPipPip
  • Advanced Member
  • 45 posts
  • LocationToronto, Canada

Posted 02 August 2006 - 03:13 PM

I always use the Code View ONLY of Dreamweaver! Works great! And visually easier than NotePad!

Just make sure to never EVER go to the Design View and try doing anything there!

Another good software (free) is TextPad (it also colour - codes just like Dreamweaver and does not add any extra characters).
Yana




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users