Jump to content


Photo

coding or server???


  • Please log in to reply
4 replies to this topic

#1 w4seem

w4seem
  • Members
  • PipPip
  • Member
  • 18 posts

Posted 26 July 2006 - 05:55 PM

hi all,

im struggling to find out whether it is the coding or the server which is slowing my site down.
whenever i search for anything on the database it seems to run slow, but im informed that the coding is not the problem?

is there anyway i can check to see what is causing the slow down??

im new to this so basic explantion would be helpful.

the site is...



#2 w4seem

w4seem
  • Members
  • PipPip
  • Member
  • 18 posts

Posted 26 July 2006 - 05:57 PM

www.studyleave.com

its basically a book shop.

thanks

#3 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 26 July 2006 - 06:02 PM

Does it only slow down when you are searching the database? If thats the case you might want to try and optimize your query, or normalize your database.

#4 king arthur

king arthur
  • Members
  • PipPipPip
  • Advanced Member
  • 335 posts
  • LocationUK HQ

Posted 26 July 2006 - 07:38 PM

Have you put indexes on the columns you are searching? That will make a big difference.
Sir Isaac Newton said "If I have seen farther, it is by standing on the shoulders of giants". But it is not recorded as to whether he said it before or after he was hit on the head by a falling apple.

#5 w4seem

w4seem
  • Members
  • PipPip
  • Member
  • 18 posts

Posted 27 July 2006 - 11:01 AM

Indeed the slowdown is only present when you search for something in the database.
The database file is originally a txt file which is couple around 250 megabytes (around 500,000 book titles, price, isbn, description etc)

also indexes are in place, im not sure how to optimize my query?

please help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users