Jump to content

Archived

This topic is now archived and is closed to further replies.

jdz66

Zendframework Setup Problem.

Recommended Posts

I have Book & book Code for "Practical Web 2.0 Applications with PHP"

(apress.com/Apress Publication) I am facing problem to setup  the application.

 

 

I am getting following errors :

 

" Warning: require_once(Zend/Loader.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\zendframework\htdocs\index.php on line 2

 

  Fatal error: require_once() [function.require]: Failed opening required 'Zend/Loader.php' (include_path='.;\xampp\php\pear\') in C:\xampp\htdocs\zendframework\htdocs\index.php on line 2 "

 

 

 

Changed "chapter-14" folder name  to "php folder

and copied to "C:\xampp\htodcs" Keeping subdirectory

structures.Also copied "zend" folder to

"C:\xampp\htdocs\include" keeping directory structuer intact.

 

 

For your reference my develpment server's details :

 

1) Window XP Professional (Service Pack2)

 

  XAMPP 1.7.0 (http://apachefriends.org)

 

  Apache        : 2.2.11

  PHP Version    : 5.2.8

  GD            : 2.1.9

  Mysql          : 5.1.30

  Mysqli        : 5.1.3

  PDO Support Enabled

 

 

2) c:\xampp\htdocs\phpweb20\include\zend

 

3)  My httpd.conf setting

 

    <VirtualHost 127.0.0.1>

    ServerName phpweb20

    DocumentRoot /xampp/htdocs/phpweb20/htdocs

 

    <Directory /xampp/htdocs/phpweb20/htdocs>

        AllowOverride All

        Options All

    </Directory>

 

    php_value include_path .:/xampp/htdocs/phpweb20/include:/xampp/php/pear:/xampp/htdocs/phpweb20/include/zend

    php_value magic_quotes_gpc off

    php_value register_globals off

 

    SetEnv APP_CONFIG_FILE "settings.ini"

    SetEnv APP_CONFIG_SECTION "development"

    </VirtualHost>

 

 

Share this post


Link to post
Share on other sites

Have you started with chapter 1, or are you jumping to chapter 14? I have this book, and it was somewhat difficult to set up... I'd recommend reading the beginning of the book if you haven't already.

Share this post


Link to post
Share on other sites

I am guessing you forgot to add the Zend FrameWork path to your php.ini file

 

look for "Paths and Directories" in it...

Share this post


Link to post
Share on other sites

Post up your index.php file as well

Share this post


Link to post
Share on other sites

what version of Zend Framework does the book use? What version of the framework are you using?

 

Make sure their both the same...there might be some small changes that might cause unexpected errors like such.... :-)

Share this post


Link to post
Share on other sites

Thanks, (Shlumph,Dgoosens and DarkSuper)  very much for

taking  your valuable time & pain to read my post and replying

at very stunning speed.

 

1) I renamed chapter 14 to "phpweb20"  and copied to "c:\xampp\htdocs\"

 

    root          - c:\xampp\htdocs\

    application    - c:\xampp\htdocs\phpweb20\

                    - c:\xampp\htdocs\phpweb20\include\zend

 

 

 

2) I gone thru all chapters and each and every page.

 

3) My php.ini (also php5.ini) setting

  include_path = ".;\xampp\php\pear\;\xampp\htdocs\phpweb20\include\;\xampp\htdocs\phpweb20\include\zend\"

 

4) I kept default index.php which is bundled with book's code howver I am posting at forum for your ref.

 

5)  Zend Framework 1.0.2 (as book is stating)

 

 

 

[attachment deleted by admin]

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.