Jump to content


Photo

Problem making index.php default page


  • Please log in to reply
3 replies to this topic

#1 Eiolon

Eiolon
  • Members
  • PipPipPip
  • Advanced Member
  • 357 posts

Posted 28 July 2006 - 08:36 PM

I used the following guilde to install PHP 4.4.2 on IIS6. 

http://www.simongibs...tranet/php2003/

Everything works but I have a problem.  The only file is index.php where I have the php info.  I can view the file if I go to http://localhost/index.php

However, if I go to http://localhost it gives me a directory listing. 

In IIS I have index.php as the default page (and deleted all others in the list so its the only one).  I also made sure index.php is the only file in my wwwroot folder.

If I create a file called index.htm it has no problem showing up immediately, even if index.php is the default page.

Any suggestions?

Thanks!

#2 crashmaster

crashmaster
  • Members
  • PipPipPip
  • Advanced Member
  • 169 posts
  • LocationCzech Republic, Prague

Posted 28 July 2006 - 08:39 PM

man..try to use easyphp !!

www.easyphp.org
I'll never be the same...

#3 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 28 July 2006 - 08:44 PM

I think you need to restart ISS in order for the new ISS settings to come available.

#4 Eiolon

Eiolon
  • Members
  • PipPipPip
  • Advanced Member
  • 357 posts

Posted 28 July 2006 - 10:02 PM

I found the problem.  I can only change the default page for a specific website and not all of them at once like I was trying to do.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users