Jump to content

Archived

This topic is now archived and is closed to further replies.

psionmam

newbie installation

Recommended Posts

Hi

I'm running windows xp home

I've loaded apache amd mysql and php and tried to configure php using

http://www.thesitewizard.com/archive/installphp.shtml

When I try to run

<?phpinfo()?>

I just get a blank browser page

Any ideas ?

Thanks


Share this post


Link to post
Share on other sites
Use the full PHP opening tag (<?php):
[code=php:0]<?php
phpinfo();
?>[/code]

Share this post


Link to post
Share on other sites
Thanks for your help guys

I inserted the colon, but still no joy

I installed apache, mysql and php yesterday

That script was first attempt to get going. As I get nothing is it possible that something else is wrong?

Is this the right place to ask? Where can I turn for help?  ???

Share this post


Link to post
Share on other sites
Did you use my suggestion, usoing the full PHP opening tag - <?php

Looking at that guide it is a little old. I suggest you do the following to configure Apache with PHP. First find the httpd.defualt.conf file. Now rename this to httpd.conf to overright the existing httpd.conf file.

Now you have reset the config file back to defualt. Find this:
[code]#LoadModule ssl_module modules/mod_ssl.so[/code]
Add the following after it:
[code]LoadModule php5_module "C:/php/php5apache2.dll"
PHPIniDir "C:/WINDOWS"[/code]
If you have PHP4, use this instead of the php5_module line:
[code]LoadModule php4_module "C:/php/isapi/php4apache2.dll"[/code]
Now scroll down and find the following:
DirectoryIndex and add index.php to the end of the list, making sure you add a space between the last entry in the list, like so:
[code]DirectoryIndex index.html index.html.var index.php[/code]
Now find the following:
[code]AddType application/x-gzip .gz .tgz[/code]
now add the following after it:
[code]AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-phps .phps[/code]
Now save the httpd.conf file. Find the php.ini file and move it to C:\WINDOWS if you haven't done so already.
Now restart Apache Server.

If Apache starts with no beeps or errors appearing. Then Apache has been configured to parse PHP files with the PHP Intepreter. Now try running your php file again.

Share this post


Link to post
Share on other sites
Thanks for your help guys

I've taken the line of least restaance and used wamp. didn't know it was there before  :-\

seems to working fine  now  :)

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.