Jump to content

Archived

This topic is now archived and is closed to further replies.

feelingsheepish

installation help - .php open in text editor

Recommended Posts

Hi,
I have installed PHP with MySQL and Apache.
When i execute the test file (<? phpinfo(); ?>) via my localhost it opens in notepad.
Please help it's been driving me crazy.

Thanks in advance

Share this post


Link to post
Share on other sites
You are going to http://localhost/ and then clicking on the file you want to run? If you are and its opening up within notepad then Apache appears to bemisconfigured. How have you configured Apache to parse PHP files with the PHP Intepreter? What tutorial did you follow to install Apache, PHP and MySQl.

Share this post


Link to post
Share on other sites
Hi,
I am going to [u]http://localhost/test.php[/u] and the file is opening into notepad. I have used the tutorial in the book "php and mysql web development" to configure my web server. I included the following lines in my httpd config file.

LoadModule php5_module c:/php/php5apache.dll
AddModule mod_php5.c
AddType aqpplication/x-httpd-php .php
Action application/x-httpd-php "/php/php.exe"

I have used this tutorial in the past and everything has worked so don't understand why it is not working.

Share this post


Link to post
Share on other sites
Did you restart Apache when you made the changes to the httpd.conf file. Also is Apache starting up with any errors/beeps? Other than that I cannot see why it is doing that.

Share this post


Link to post
Share on other sites
[quote]AddType aqpplication/x-httpd-php .php[/quote]

Dunno if you saw this or have figured it out, but you misspelled application. That could cause your problem.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.