Jump to content

Archived

This topic is now archived and is closed to further replies.

chewbacca5000

Please, critique my new site freelancejobsusa.com

Recommended Posts

Please, critique my new site [url=http://www.freelancejobsusa.com]www.freelancejobsusa.com[/url]

All feedback, comments, and suggestions are welcome.

Thank You

Share this post


Link to post
Share on other sites
It's a good start.

Your objects are all broken apart the header is to the left, the content below the header is centered, the middle banner is all split apart, and everything else is kind of centered.

Your links on the top: Home is fine, find freelancers is too much to the left, find jobs looks like its a little to the left, job center is too much to the right.

There are a lot more alignment and spacing problems throughout the site. If you fix those it looks like there is some potential.

-Chris

Share this post


Link to post
Share on other sites
Thanks for the review.

What did you mean when you said my objects are broken apart?  Do you mean how the objects are positioned relative to each other, or that there is gaps/spaces in the objects ie. middle banner text is off, or there are spaces that shouldn't be there.

Be sure to check out the specialties for php.  I am interested to know what you think. 

Do I have too many specialties or not enough?
Do you like the idea of being able to specialize in a category such as PHP/MYSQL or PHP/Real Estate?
Are there any specialties you would add?

Thanks

Kyle

Share this post


Link to post
Share on other sites
Yes, I have looked at my site using Internet Explorer version 6 at a screen res of 1024 by 768. 

What version are you using, and what am I missing. 

I am not a designer by trade.

Thanks

Kyle

Share this post


Link to post
Share on other sites
Here is a screen shot of mine

[attachment deleted by admin]

Share this post


Link to post
Share on other sites
Ok, so it is literally pulled apart. 

What browser and what version are you using?

Any ideas on how I can fix it?

Share this post


Link to post
Share on other sites
I'm using Opera 9 and getting the same issues as the others.  Your photo in the yellow part is also VERY fuzzy... i'd try to sharpen that up or find a different one.  Other than that, I'd say you've got a nice looking site. I like the logo too.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.