Jump to content

Archived

This topic is now archived and is closed to further replies.

tantinga

Please help!!! Echo Problem reading from php/flash

Recommended Posts

Hello, I have a small problem which is big if I can't find a way out, lol.  I have a mainframe.swf, in this I have an empty movie clip.  Thru this empty movie clip I am loading several other .swf files.  One of those files is my mailform.swf.  It worked great alone but once I loaded it thru the empty movie clip, it didn't send the echo ("thank you, your mail sent" etc) for flash to read out in the box named "answer".  But it still sends the mail to both myself and the person.  Here's the part of code in the php script that I think pertains to my problem:

CODE--------------------------------------------

$sendresult = "Thank you. ";
$send_answer = "answer=";
$send_answer .= rawurlencode($sendresult);
echo "$send_answer";

END CODE---------------------------------------

[color=red]How can i make this php script work correctly so that the echo is sent to flash.[/color]
Thank you to whom may be able to help me....  :)

Share this post


Link to post
Share on other sites
Let me know if this works for you or not

[code]

echo "&answer=$send_answer&";

[/code]

Share this post


Link to post
Share on other sites
You need to add some Action scrript into the flash
load_variables I think it is
Not 100% sure, so dont hold me against that

Share this post


Link to post
Share on other sites
yea, the above example should work provided that you created a loadVars object in your action script but I figured we should get the php right first and go from there

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.