Jump to content

Archived

This topic is now archived and is closed to further replies.

Re-JeeP

Force to view a *.phps page

Recommended Posts

Hi!

I'm using this link to view a script.
<a href="script.phps" target="_blank">Script</a>

But it dosen't show the page, it pops up a downloader instead.

I searched some infomation about it and a header seemed to solve it.

But i don't realy now how to use it!

Any ideas?

// Johan

Share this post


Link to post
Share on other sites
phps aint reconized as a MIME type on your server
use the normal php extension
or set up a new MIME type

Share this post


Link to post
Share on other sites
YOu server will need to be configured to to parse .phps files with the PHP Highlighter. With Apache you can add this to the httd.conf or .htaccess (i think):
[code]AddType application/x-httpd-phps .phps[/code]

Share this post


Link to post
Share on other sites
[quote]AddType application/x-httpd-phps .phps[/quote]
I tried to put the text into a .htaccess-file but it didn't work.

Since I can't get access to httpd.conf I need some other solution!

Share this post


Link to post
Share on other sites
If you can find mime.types, insert this on to the end of it:
application/x-httpd-phps .phps


Or you could try whereis httpd.conf in the bash shell.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.