Jump to content

cakephp page not displaying


Recommended Posts

I created a virtual host and moved my entire cake folder to this directory but it looks like the page is not seeing my css file. All images are broken and the layout gone. Any help.


here is my virtualhost line in apache

<Directory "C:/nweev">
  Order Deny,Allow
  Allow from all


  DocumentRoot "C:/nweev/new_iweev/"
  ServerName new_iweev


I moved the entire cake files into new_iweev.

Link to comment
Share on other sites

I did that already and it displayed the homepage only. When I clicked to view other pages I got a broken link.

Define what you mean by "homepage only". And what other pages are you refering to with:

When I clicked to view other pages I got a broken link


Do the images on your "homepage" display correctly though?

Link to comment
Share on other sites

ok I did it a different way...left the folder in my htdocs, created a virtualhost like this


  DocumentRoot C:/webserver/htdocs/mytestsite/app/webroot
  ServerName mytestsite


when i type in http://mytestsite, everything works fine. This may probably be a question for the apache server forum, but I want everyone on my network to be able to view http://mytestsite. Instead of seeing my page, they are getting "It Works" which is apache's default page for successful installation. What do I need to do to point to my cakephp website?

Link to comment
Share on other sites

This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.