Jump to content


Photo

extensions without root-rights not found


  • Please log in to reply
2 replies to this topic

#1 jmc

jmc
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 07 August 2006 - 01:12 PM

Hi,
I have the problem, that the mysql-extension is not being found, when running scripts from the commandline (cli). If i execute the very same command from the root account, there is no problem at all: Everything works fine then. Otherwise i get
Fatal error: Call to undefined function mysql_connect()
messages.
The file mysql.so plus its directory both have the usual access rights (644), so there is no problem for the user reading the library. (And yes, the library does exist :)
Somebody knows how to make php load the libraries from ordinary user accounts?
greetings,
jmc

#2 manmadareddy

manmadareddy
  • Members
  • PipPipPip
  • Advanced Member
  • 50 posts

Posted 08 August 2006 - 07:07 AM

You need to enable the extension in php.ini

#3 jmc

jmc
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 08 August 2006 - 02:07 PM

Hi,
yes, thx. i found that. It was at the end of the file unlike the windows extensions -_-
Now there remains the problem that the .ini is not being parsed (its in /etc/php5/cli). Since its not being even read, the mysql extension is not loaded. Now, i could load it with dl(), but i want it to be loaded on startup with extension=mysql.so.
The ini-File is world-readable, so that should not be the problem ...
thx,
jmc




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users