Jump to content

Archived

This topic is now archived and is closed to further replies.

angelb0y

(SOLVED) Includes and Requires (Mac OS X)

Recommended Posts

Hi Peeps

I'm new here, well the 1st post says it all :D

i've recently moved from pc to mac but i know both have apache installed. yet how come they act so different. i cannot for the life of (i wont say it) get the include or require functions to work and when i use them they just output blank pages regardless of whats in the page.

Any help would be soooooooooooooo much appreciated.

Thanks Peeps
Angel

Share this post


Link to post
Share on other sites
That really makes no sense.  Do you have display_errors set to display errors?  Perhaps you don't and the problem is that you're using the wrong filename path?

So far, and aside from the problem you wrote about, how do you like using the Mac compared to the PC?

Share this post


Link to post
Share on other sites
mmmm.... i will try and rip apache apart later.

well moving from pc to mac, initially like anything you got to get used to it. Its very different but I dont think i'll ever turn back. Its not a super computer (G5 Dual Core) but with alot of memory its really fast.

I'll have to find apache's working directory somewhere later
Thanks bitesar :)

Share this post


Link to post
Share on other sites
OK, this for all you Mac OS X users.

Apache was begging me to stop torchering it.  :D

Since some may know the Mac is sort of locked down in user graphical mode and to configure apache needs some terminal typing. Right, now open a terminal session under the "applications/utilities" and type "sudo su" (this means log in with super user rights) it will then ask you for a password which is the same as your own admin account. Now that you have given yourself permissions to destroy your Mac be carefull, the following are the locations for the files that need editing to allow includes and requires to work (why they don't beats me in the first place).

httpd.conf = /etc/httpd/
php.ini = /usr/local/php5/lib/

what I did is copy the files to my desktop edit them and copy them back. So copy them like this then:

to copy to desktop = cp filename.extension /users/"username"/desktop
to copy from desktop back httpd = cp /users/"username"/desktop /etc/httpd
to copy from desktop back httpd = cp /users/"username"/desktop /usr/local/php5/lib/

substitute filename.extension with the real names and "username" with the account name logged in.


I edited the needed stuff and all functions now work.

*previous removed --> me being idiot*

NOTE: If an Admin see fit to move it please do so. :)

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.