Jump to content

Archived

This topic is now archived and is closed to further replies.

shehroz

virtual host error

Recommended Posts

i have added below code to httpd.conf, but i could not restart the server. it says error.


NameVirtualHost 111.22.33.44

    <VirtualHost 111.22.33.44>
    ServerName www.domain.tld
    ServerPath /domain
    DocumentRoot /web/domain
    </VirtualHost>

what is my error in this code?

Share this post


Link to post
Share on other sites
You havent got a proper document root you cant have your document root your domian name you need to place your server files like your Mp3 , Txt and etc files as your document root

Share this post


Link to post
Share on other sites
[quote]
[quote]
i have added below code to httpd.conf, but i could not restart the server. it says error.

NameVirtualHost 111.22.33.44

    <VirtualHost 111.22.33.44>
    ServerName www.domain.tld
    ServerPath /domain
    DocumentRoot /web/domain
    </VirtualHost>

what is my error in this code?
[/quote]

It should look something like

NamedVirtualHost your IP address

<VirtualHost xxX.xxx.xxx.xxx>
  ServerName domain.tld
  ServerAlias www.domain.tld
  ServerAdmin you@youremail.address
  DocumentRoot /path/to/your/web/files
    <Directory /path/to/your/web/files>
        Order Allow,deny
    </Directory>
  </VirtualHost>


Do not forget that the server will have to be restarted after making any changes to the httpd.conf file

Share this post


Link to post
Share on other sites
Just change it to


VirtualHost xxX.xxx.xxx.xxx>
   ServerName domain.tld
   ServerAlias www.domain.tld
   ServerAdmin you@youremail.address
   DocumentRoot /path/to/your/web/files
     <Directory /path/to/your/web/files>
        Order Allow,deny
     </Directory>
  </VirtualHost>

BTW the xxx arent kisses thats your local ip address

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.