Jump to content


This topic is now archived and is closed to further replies.


Newbie with really old Dreamweaver

Recommended Posts

I know that this is a long shot and that 1.2a is really old, but here goes.


I voluntarily manage a small charity site at http://www.swedauk.org with Dreamweaver 1.2a. There is no budget so I have to use what software I can get together myself and this is the only site I have done (plus a previous incarnation of the same). All in all things haven't gone too badly and we have a useable, if rather bland, site.


I have recently tried inserting some php code into a webpage to do some simple blogging (B2) but as soon as Dreamweaver gets hold of the file it turns it into unsuable mush. Just inserting the following -


<?php /* Don't remove this line, it calls the b2 function files ! */ $blog=1; include ("blog.header.php"); ?>


breaks the page. The more complex bits of php just makes things worse. Doing the same in a text editor and uploading works fine and everything works as expected.


Just opening a usuable html document with some php into Dreamweaver and saving it straight out again results in a radically different and totally unusable file.


I appreciate that 1.2a is pre php but isn't is simple meant to ignore everything between the <?php and ?> tags?


I've tried disabling everything in preferences that modifies or 'corrects' the source but with no luck.


Does anyone know of anyway I might include php in a document without Dreamweaver 1.2a wrecking it?


Any thoughts would be gratefully accepted.


With Kind Regards,


Share this post

Link to post
Share on other sites

im unsure of how to solve your problem, but did you know that Dreamweaver MX 2004 has a free trial?


also, there is a program called UltraEdit 32 and a very popular tool - Im not sure if it is free or no though.

Share this post

Link to post
Share on other sites

Thanks Hotdog, I'll have a look.


I have finally managed to solve my Dreamweaver problem. Apparently PHP will recognise the ASP deliminators - <% %> - as long as it is configured to do so in PHP.ini which my host has kindly done for me.


Dreamweaver treats anthing withing these as a comment and leaves them along.


Thanks again for your tips.



Share this post

Link to post
Share on other sites


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.