Jump to content

Archived

This topic is now archived and is closed to further replies.

akop

EXIF installation

Recommended Posts

Hi,

I've got new hosting but there is no [b][color=red]exif[/color][/b] in their php. I tried to call for support and their said to me that the only thing I can do is to try to use custom php.ini that will override native configuration. I’m principally familiar with this method but I’m not quite sure that it is really possible to get exif working on the linux server where php was not originally compiled with [b][color=red]exif[/color][/b].

Any suggestions would be very much appreciated!
akop

Share this post


Link to post
Share on other sites
Run this:
[code=php:0]<?php
phpinfo();
?>[/code]

Look in the [b]Configure Command[/b] row. Look in the coloumn next to it to see whether you can see [i]--enable-exif[/i]

if not then you'll have to see if your host will recompile PHP with the [i]--enable-exif[/i] command option. As thats the only way to enable the exif extension on a unix based server.

Also before you ask your host make sure your site is not hosted of a Windows box, by running the code above look for the [b]System[/b] row. To the right of that it should state what OS the server is running on. If its Windows then you should be able to enable it through the php.ini.

Share this post


Link to post
Share on other sites
Thank you wildteen88,

It is linux hosting and there is no exif in phpinfo and I actually tried to ask my hosting provider whether it is possible to change php configuration but the only answer I got - is that "You can enable modules within your php.ini file."
They do not want to provide any farther assistance.  >:(

regards,
akop

Share this post


Link to post
Share on other sites
It's possible that they have modules sitting in the directory listed in the "extension_dir" that you can use. If they're compiled after the initial core php installation there won't be a listing in phpinfo. I'm assuming this is a CGI setup, seeing how I don't know how they'd do this otherwise (ie your custom php.ini). This [b]is[/b] shared hosting?

Look for the following line in your php.ini and remove any ";" that may be at the beginning of the line.
[code]
extension=exif.so
[/code]
If it's not there, try adding it.

It's also possible the person you spoke to doesn't really know the answer or is purposely misleading you.

Share this post


Link to post
Share on other sites
Hi shoz,

I appreciate your help!

Yes this is a shared histing.

I looked for extension_dir in the phpinfo() and it is [color=orange]/usr/local/lib/php/extensions/no-debug-non-zts-20020429[/color]. It looks like I have no access to it.

I tryed to put extension=exif.so into my custom php.ini and it didn't help. At the same time I got new reply from provider:
[color=red]"Thank you for contacting customer support. Unfortunately, we cannot install this module. If you wish to have control over the server to install your own module you will need to purchase a virtual dedicated or dedicated server. We apologize for the confusion"[/color]

Since I don't want to pay even more then I do now for such simple thing like exif support I'm canceling my account with this provider.

I thank you all for your help!
akop

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.